hdu 1885 Key Task(状态压缩+bfs)

Problem Description
The Czech Technical University is rather old — you already know that it celebrates 300 years of its existence in 2007. Some of the university buildings are old as well. And the navigation in old buildings can sometimes be a little bit tricky, because of strange long corridors that fork and join at absolutely unexpected places. 

The result is that some first-graders have often di?culties finding the right way to their classes. Therefore, the Student Union has developed a computer game to help the students to practice their orientation skills. The goal of the game is to find the way out of a labyrinth. Your task is to write a verification software that solves this game. 

The labyrinth is a 2-dimensional grid of squares, each square is either free or filled with a wall. Some of the free squares may contain doors or keys. There are four di?erent types of keys and doors: blue, yellow, red, and green. Each key can open only doors of the same color. 

You can move between adjacent free squares vertically or horizontally, diagonal movement is not allowed. You may not go across walls and you cannot leave the labyrinth area. If a square contains a door, you may go there only if you have stepped on a square with an appropriate key before. 
 

Input
The input consists of several maps. Each map begins with a line containing two integer numbers R and C (1 ≤ R, C ≤ 100) specifying the map size. Then there are R lines each containing C characters. Each character is one of the following: 



Note that it is allowed to have 
  • more than one exit, 
  • no exit at all, 
  • more doors and/or keys of the same color, and 
  • keys without corresponding doors and vice versa. 

    You may assume that the marker of your position (“*”) will appear exactly once in every map. 

    There is one blank line after each map. The input is terminated by two zeros in place of the map size. 
 

Output
For each map, print one line containing the sentence “Escape possible in S steps.”, where S is the smallest possible number of step to reach any of the exits. If no exit can be reached, output the string “The poor student is trapped!” instead. 

One step is defined as a movement between two adjacent cells. Grabbing a key or unlocking a door does not count as a step. 
 

Sample Input
  
  
1 10 *........X 1 3 *#X 3 20 #################### #XY.gBr.*.Rb.G.GG.y# #################### 0 0
 

Sample Output
  
  
Escape possible in 9 steps. The poor student is trapped! Escape possible in 45 steps.

在一个地图中从*走到x,地图中有墙,4个门和对于的钥匙,问最少的步数,应该可能需要来回的去找钥匙,所以需要重复走某个点,不能简单的进行标记了,但是如果重复走相同的一个点时,它的状态是不一样的(拿没拿到钥匙,有哪几把钥匙),所以除了标记位置外,还要标记其状态,状态决定是否走这一步,因为有4把钥匙,因此有16个状态,用4位二进制表示4把钥匙的状态。然后就差不多了。。。


  1.  
  2. #include<iostream>

    #include <stdio.h>

    #include <queue>

    #include <string.h>

    using namespace std;

    char map[105][105];

    bool vis[105][105][17];

    int sx,sy,r,c;

    int dir[4][2]={{1,0},{-1,0},{0,1},{0,-1}};

    struct node

    {

        int x;

        int y;

        int step;

        int state;

        node(int x=0,int y=0,int step=0,int state=0)

        {

            this->x=x;

            this->y=y;

            this->step=step;

            this->state=state;

        }

    };


    int check(int x,int y)

    {

        if(x<0 || x>=r || y<0 || y>=c ||map[x][y]=='#')

            return false;

        return true;

    }


    bool door(node &t)

    {

        if(map[t.x][t.y]=='B')

        {

            if (t.state&1)

                return true;

            return false;

        }

        else if(map[t.x][t.y]=='Y')

        {

            if (t.state&2)

                return true;

            return false;

        }

        else if(map[t.x][t.y]=='R')

        {

            if (t.state&4)

                return true;

            return false;

        }

        else if(map[t.x][t.y]=='G')

        {

            if (t.state&8)

                return true;

            return false;

        }

        return false;

    }

    int bfs()

    {

        queue<node>q;

        node temp,h;

        q.push(node(sx,sy,0,0));

        vis[sx][sy][0]=1;

        while (!q.empty())

        {

            temp=q.front();

            q.pop();

            for (int i=0; i<4; i++)

            {

                h=temp;

                h.x+=dir[i][0];

                h.y+=dir[i][1];

                h.step++;

                if(check(h.x, h.y)&& !vis[h.x][h.y][h.state])

                {

                    if (door(h))//门,有钥匙

                    {

                        vis[h.x][h.y][h.state]=1;

                        q.push(h);

                    }

                    //有门,没钥匙,不可行

                    

                    //没门,是钥匙(判断钥匙类型)

                    else if(map[h.x][h.y]=='b' && !vis[h.x][h.y][h.state|1])

                    {

                        vis[h.x][h.y][h.state|1]=1;

                        h.state=h.state|1;

                        q.push(h);

                    }

                    else if(map[h.x][h.y]=='y' && !vis[h.x][h.y][h.state|2])

                    {

                        vis[h.x][h.y][h.state|2]=1;

                        h.state=h.state|2;

                        q.push(h);

                    }

                    else if(map[h.x][h.y]=='r' && !vis[h.x][h.y][h.state|4])

                    {

                        vis[h.x][h.y][h.state|4]=1;

                        h.state=h.state|4;

                        q.push(h);

                    }

                    else if(map[h.x][h.y]=='g' && !vis[h.x][h.y][h.state|8])

                    {

                        vis[h.x][h.y][h.state|8]=1;

                        h.state=h.state|8;

                        q.push(h);

                    }

                    //是路

                    else if(map[h.x][h.y]=='.')

                    {

                        vis[h.x][h.y][h.state]=1;

                        q.push(h);

                    }

                    //是出路

                    else if(map[h.x][h.y]=='X')

                        return h.step;

                }

            }

            

            

        }

        return -1;

    }


    int main()

    {

        while(scanf("%d%d",&r,&c) && (r||c))

        {

            getchar();

            for (int i=0; i<r; i++)

            {

                for (int j=0; j<c; j++)

                {

                    scanf("%c",&map[i][j]);

                    if(map[i][j]=='*')

                    {

                        sx=i;

                        sy=j;

                        map[i][j]='.';//注意这里需要改一下

                    }

                }

                getchar();

            }

            

            memset(vis,0, sizeof(vis));

            int ans=bfs();

            if(ans>0)

                printf("Escape possible in %d steps.\n",ans);

            else

                printf("The poor student is trapped!\n");

        }

        

        return 0;

    }







评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值