Hduoj1358 【KMP】

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.

Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
Sample Input
3
aaa
12
aabaabaabaab
0
 
Sample Output
Test case #1
2 2
3 3
Test case #2
2 2
6 2
9 3
12 4
 
 
#include <stdio.h>
char s[1000005];
int next[1000005];
void getnext(int x) {
 int i=0,j=-1;
 next[0]=-1;
  while(i<x) {
   if(j==-1||s[i]==s[j]){
    i++;j++;
  //  if(s[i]==s[j])   这三行是next的优化,此处不需要
   //   next[i]=next[j];
  //  else
      next[i]=j;
   }
   else j=next[j];
  }
}

int main()
{
 int i,n,p=0;
 while(scanf("%d",&n),n) {
  scanf("%s",s);
  getnext(n);
  printf("Test case #%d\n",++p);
  for(i=2;i<=n;i++){      //关键在这里 
  //类似 len 如果能整除 len-next[len],
  //那么重复的次数就是  len/(len-next[len])
  //不能整除就没有重复串
   int t=i%(i-next[i]);
   int k=i/(i-next[i]);
   if(t==0&&k>1) printf("%d %d\n",i,k);
  }
  puts("");
 }
}

//附上原理

kmp next函数 kmp的周期问题,深入了解kmp中next的原理

-----------------------

-----------------------

 k    m        x      j       i

由上,next【i】=j,两段红色的字符串相等(两个字符串完全相等),s[k....j]==s[m....i]

设s[x...j]=s[j....i](xj=ji)

则可得,以下简写字符串表达方式

kj=kx+xj;

mi=mj+ji;

因为xj=ji,所以kx=mj,如下图所示

 

-------------

      -------------

 k   m        x     j   

看到了没,此时又重复上面的模型了,kx=mj,所以可以一直这样递推下去

所以可以推出一个重要的性质len-next[i]为此字符串的最小循环节(i为字符串的结尾),另外如果len%(len-next[i])==0,此字符串的最小周期就为len/(len-next[i]);

原文链接:http://blog.sina.com.cn/s/blog_792e6df50100wkps.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值