Poj2689【素数筛选】

/*Prime Distance
Time Limit: 1000MS		Memory Limit: 65536K
Total Submissions: 14957		Accepted: 3965
Description

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers.
Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).
Input

Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.
Output

For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.
Sample Input

2 17
14 17
Sample Output

2,3 are closest, 7,11 are most distant.
There are no adjacent primes.
Source

Waterloo local 1998.10.17*/

#include<stdio.h>
#include<string.h>
int L, R, prime[100010];
void getprime()              //筛选1~100010的素数
{
    memset(prime, 0, sizeof(prime));
    for(int i = 2; i < 100010; ++i)
    {
        if(!prime[i])
            prime[++prime[0]] = i;     //保存素数
        for(int j = 1; j <= prime[0] && prime[j] <= 100010/i; ++j)
        {
            prime[i*prime[j]] = 1;    //素数的倍数为非素数
            if(i % prime[j] == 0)    //优化
                break;              //如果i为某个素数的倍数则不必再×后面的素数
                                  //因为i×后面大的素数 = 比i大的数×前面小的素数
        }
    }
}
int prime2[1000010], notprime[1000010];//区间相差不会超过1000000数量级
void getprime2()
{
    memset(notprime, 0, sizeof(notprime));
    if(L < 2)                            //1不是素数,为保证下方prime2的最小素数为2
    L = 2;
    for(int i = 1; i <= prime[0] && (long long)prime[i]*prime[i] <= R; i++)//筛选出非素数
    {
        int s = L/prime[i] + (L%prime[i] > 0 );//保证j*prime[i]从比L大的地方开始
        if(s == 1)
        s = 2;
        for(int j = s; (long long)j*prime[i] <= R; ++j)
        {
        //    if((long long) j*prime[i] >= L)  //此步可有可无
                notprime[j*prime[i]-L] = 1;
        }
    }
    prime2[0] = 0;
    for(int i = 0; i <= R-L; ++i)
    {
        if(!notprime[i])              //当i= 0时,L必须为2作为第一个素数
        prime2[++prime2[0]] = i+L;     //保存L~R的素数
    }
}
int main()
{
    int i, j, k;
    getprime();
    while(scanf("%d%d", &L, &R) != EOF)
    {
        getprime2();
        int x1 = 0, x2 = 100000010, y1 = 0, y2 = 0;
        if(prime2[0] < 2)
        printf("There are no adjacent primes.\n");
        else
        {
            for(i = 1; i < prime2[0]; ++i)
            {
                if(prime2[i+1] - prime2[i] < x2-x1)
                {
                    x2 = prime2[i+1];
                    x1 = prime2[i];
                }
                if(prime2[i+1] - prime2[i] > y2-y1)
                {
                    y2 = prime2[i+1];
                    y1 = prime2[i];
                }
            }
            printf("%d,%d are closest, %d,%d are most distant.\n", x1,x2,y1,y2);
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值