ZOJ 1709 Oil Deposits

原题传送门:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=1709

Oil Deposits

 


 

Time Limit: 2 Seconds      Memory Limit: 65536 KB

 


The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.


Input

 

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

 


Output

 

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

 


Sample Input

 

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

 


Sample Output

 

0
1
2
2

 


Source: Mid-Central USA 1997

 

 

分析:这道题目也就是简单的图的遍历和统计,主要思路有BFS和DFS,两种方法都可行,这里我用BFS来解决这道题目。主要思路就是用for for 找到一个‘@’,然后以它为首结点开始遍历与之相邻(上下左右。左上,左下,右上,右下)的所有‘@’,用一个空的队列保存每次读取到的结点,用while(!queue.empty()),来控制相邻油田块遍历,每次pop()出结点就访问它的相邻点,如果是@就放到队列,队列为空,就是while结束,那么就有油田数量就加1;访问过的@要做标记,以免for for中重复访问,这样最后输出的count(油田数量)就是问题的答案

 

源代码:

//图的BFS ZOJ 1709
#include <stdio.h>
#include <queue>
#include <string.h>
using namespace std;
const int MAXN = 101;
char list[MAXN][MAXN];
bool isVisited[MAXN][MAXN];
int m,n,count;
struct Pos{
    int x;
    int y;
};

void BFS(Pos pos,int m,int n){
    queue<Pos> bfque;
    bfque.push(pos);
    while(!bfque.empty()){
        Pos temp = bfque.front();
        bfque.pop();
        if(list[temp.x-1][temp.y] == '@' && temp.x-1>0 && !isVisited[temp.x-1][temp.y]){
            Pos newPos;
            newPos.x = temp.x-1;
            newPos.y = temp.y;
            bfque.push(newPos);
            isVisited[temp.x-1][temp.y] = true;
        }
        if(list[temp.x+1][temp.y] == '@' && temp.x+1<= m && !isVisited[temp.x+1][temp.y]){
            Pos newPos;
            newPos.x = temp.x+1;
            newPos.y = temp.y;
            bfque.push(newPos);
            isVisited[temp.x+1][temp.y] = true;
        }
        if(list[temp.x][temp.y-1] == '@' && temp.y-1>0 && !isVisited[temp.x][temp.y-1]){
            Pos newPos;
            newPos.x = temp.x;
            newPos.y = temp.y-1;
            bfque.push(newPos);
            isVisited[temp.x][temp.y-1] = true;
        }
        if(list[temp.x][temp.y+1] == '@' && temp.y+1<=n && !isVisited[temp.x][temp.y+1]){
            Pos newPos;
            newPos.x = temp.x;
            newPos.y = temp.y+1;
            bfque.push(newPos);
            isVisited[temp.x][temp.y+1] = true;
        }
        if(list[temp.x-1][temp.y-1] == '@' && temp.x-1>0 && temp.y-1>0 && !isVisited[temp.x-1][temp.y-1]){
            Pos newPos;
            newPos.x = temp.x-1;
            newPos.y = temp.y-1;
            bfque.push(newPos);
            isVisited[temp.x-1][temp.y-1] = true;
        }
        if(list[temp.x-1][temp.y+1] == '@' && temp.x-1>0 && temp.y+1<=n && !isVisited[temp.x-1][temp.y+1]){
            Pos newPos;
            newPos.x = temp.x-1;
            newPos.y = temp.y+1;
            bfque.push(newPos);
            isVisited[temp.x-1][temp.y+1] = true;
        }
        if(list[temp.x+1][temp.y-1] == '@' && temp.x+1<=m && temp.y-1>0 && !isVisited[temp.x+1][temp.y-1]){
            Pos newPos;
            newPos.x = temp.x+1;
            newPos.y = temp.y-1;
            bfque.push(newPos);
            isVisited[temp.x+1][temp.y-1] = true;
        }
        if(list[temp.x+1][temp.y+1] == '@' && temp.x+1<=m  && temp.y+1<=n && !isVisited[temp.x+1][temp.y+1]){
            Pos newPos;
            newPos.x = temp.x+1;
            newPos.y = temp.y+1;
            bfque.push(newPos);
            isVisited[temp.x+1][temp.y+1] = true;
        }

    }


}
main(){
     while(scanf("%d %d",&m,&n)!= EOF){
        if(m == 0&&n == 0)break;
        count = 0;
        for(int i=1;i<MAXN;i++){
            for(int j=1;j<MAXN;j++){
                isVisited[i][j] = false;
            }
        }
        for(int i=1;i<=m;i++){
            scanf("%s",list[i]+1);
        }

        for(int i=1;i<=m;i++){
            for(int j=1;j<=n;j++){
                if(list[i][j] == '@'&& !isVisited[i][j]){
                    Pos statPos;
                    statPos.x = i;
                    statPos.y = j;
                    BFS(statPos,m,n);
                    count++;
                }
            }
        }

        printf("%d\n",count++);

    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值