ZOJ 1709 Oil Deposits(油田问题DFS)

Oil Deposits

Time Limit: 2 Seconds       Memory Limit: 65536 KB

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.


Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.


Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.


Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0


Sample Output

0
1
2
2



#include<iostream>
#include<stdio.h>
using namespace std;
const int maxn=105;
char grid[maxn][maxn];
int dir[8][2]={{-1,1},{0,1},{1,1},{-1,0},{1,0},{-1,-1},{0,-1},{1,-1}};
int m,n;//之所以定义为全局变量是因为在dfs函数中要用到
int main()
{
void dfs(int,int);
while(scanf("%d%d",&m,&n)!=EOF)
{
int i,j;
if(m==0){break;}
for(i=0;i<m;i++)
{scanf("%s",&grid[i]);}//用字符串而不用双重for循环进行输入避免了字符中的空格和回车问题
int sum=0;
for(i=0;i<n;i++)
for(j=0;j<m;j++)
{
if(grid[i][j]=='@')
{
dfs(i,j);
sum++;
}
}
printf("%d\n",sum);
}
return 0;
}


void dfs(int x,int y)
{
grid[x][y]='*';
for(int i=0;i<8;i++)
{
int xi=x+dir[i][0];
int yi=y+dir[i][1];
if(xi<0||xi>=n||yi<0||yi>=m){continue;}
/*注意这里的x和y是所在位置的行数和列数,不是所在位置的横坐标和纵坐标*/
if(grid[xi][yi]=='@'){dfs(xi,yi);}
}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值