01-复杂度2 Maximum Subsequence Sum(25 分)

Given a sequence of K integers { N ​1 ​​ , N ​2 ​​ , …, N ​K ​​ }. A continuous subsequence is defined to be { N ​i ​​ , N ​i+1 ​​ , …, N ​j ​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

题目大意:
给定K个整数{N 1,N 2,…,N K}的序列。连续子序列被定义为{N i,N i + 1,…,N j},其中1≤i≤j≤K。最大子序列是其元素总和最大的连续子序列。例如,给定序列{-2,11,-4,13,-5,-2},其最大子序列为{11,-4,13},最大和为20。

现在你应该找到最大的和,连同最大次序的第一个和最后一个数字。

输入规格:

每个输入文件包含一个测试用例。每个案例都有两行。第一行包含正整数K(≤10000)。第二行包含K个数字,用空格分隔。

输出规格:

对于每个测试用例,一行输出最大和,以及最大子序列的第一个和最后一个数字。数字必须由一个空格分开,但行尾不能有空格。在最大子序列不唯一的情况下,输出具有最小索引i和j(如示例情况所示)的索引。如果所有K个数字都为负数,则其最大和定义为0,并且您应该输出整个序列的第一个和最后一个数字。

该题一开始只考虑了正数,提交时发现还有0和负数的情况,故而又花了时间做了修改。

#include<iostream>
using namespace std;
void MaxSubseqSum4( int A[], int N,int first,int last)
{
    int ThisSum,MaxSum;
    int i,Maxfirst,Maxlast;
    ThisSum=MaxSum=0;
    int flag=1;
    for(i=0;i<N;i++)
    {
        if(flag==1)
            first=A[i];
        ThisSum+=A[i];
        flag=0;
        if(ThisSum>MaxSum)
        {
            MaxSum=ThisSum;
            Maxfirst=first;
            Maxlast=A[i];
        }
        else if(ThisSum<0)
        {
            ThisSum=0;
            flag=1;
        }
    }
    if(MaxSum==0)
    {
        for(i=0;i<N;i++)
        {
            if(A[i]==0)
                break;
        }
        if(i==N)
        {   
            Maxfirst=A[0];
            for(i=0;i<N;i++)
                if(A[i]>Maxfirst)
                    Maxfirst=A[i];
            cout<<Maxfirst<<" "<<Maxfirst<<" "<<Maxfirst<<endl;
        }
        else 
            cout<<"0 0 0"<<endl;
    }
    else
        cout<<MaxSum<<" "<<Maxfirst<<" "<<Maxlast<<endl;
}
int main()
{
    int k,first,last;
    cin>>k;
    int *a;
    a=new int[k];
    for(int i=0;i<k;i++)
        cin>>a[i];
    MaxSubseqSum4(a,k,first,last);
    delete []a;
    return 0;
}

不知道为什么测试数据4全是负数一直答案错误。。。
当全是负数时,最大和不就是最大的负数,第一个和最后一个不也是这个负数吗。。。

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

程序猿S先森丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值