DFS深度优先搜索之lake counting

A - Lake Counting
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

Hint

OUTPUT DETAILS: 

There are three ponds: one in the upper left, one in the lower left,and one along the right side.




深度优先搜索DFS、
深度优先搜索,就是对于棵树而言,对于一个子树先进行遍历,一直搜索树的孩子节点,深度优先,一直到树的叶子节点,再进行回溯

对于此题,当找到一个属于‘W'时,就对该区域的八个方向就行搜索,如果搜索到水域(x1,y1),就让该水域变为’.',并继续搜索(x1,y1)的周围节点,一直到没有就跳出


java代码
import java.util.Scanner;

public class Main {
	
	static char[][] map;
	static int[][] dir={{0,-1},{-1,-1},{-1,0},{-1,1},{1,0},{1,1},{0,1},{1,-1}}; 
	boolean[][] vis = new boolean[10000][10000];
	
	
	public static void dfs(int x,int y,int row,int col){
		char c = map[x][y];
		map[x][y]='.';
		int x1,y1;
		for(int i=0;i<8;i++){
			x1=x+dir[i][0];
			y1=y+dir[i][1];
			if(x1<=0||x1>row||y1<=0||y1>col){
				continue;
			}
			if(map[x1][y1]=='W'){
				//map[x1][y1]='.';
			    dfs(x1,y1,row,col);
			}else{
				continue;
			}
			
		}
	}


	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner in = new Scanner(System.in);
		int n, m;
		while(in.hasNext()){
			int cnt=0;
			n = in.nextInt();
			m = in.nextInt();
			map = new char[n+1][m+1];
			for(int i = 1;i<=n;i++){
				String s=in.next();
				//System.out.println(s.charAt(0));
				for(int j=1;j<=m;j++){
					map[i][j]=s.charAt(j-1);
				}
			}
			for(int i=1;i<=n;i++){
				for(int j =1;j<=m;j++){
					if(map[i][j]=='W'){
						dfs(i,j,n,m);
						cnt++;
					}
				}
			}
			System.out.println(cnt);
			
		}
	}

}




















  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值