poj 1328 Radar Installation (贪心)

Radar Installation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 51376 Accepted: 11526

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
 
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

Source

该题题意是为了求出能够覆盖所有岛屿的最小雷达数目,而由题目我们可以求出每个岛屿雷达能覆盖的区间,该区间在岛屿横坐标两边对称的长度[x-sqrt(r*r-y*y),x+sqrt(r*r-y*y)];然后我们对岛屿按左区间从小到大排序,说到这里,我们脑海中就浮现出来了贪心的经典活动安排问题,把这些区间看成一个活动的【开始时间--结束时间】,要求我们尽可能地选择一个方案最多的活动,前提是活动要兼容,即时间不冲突,而所求的最多方案是就是我们要求的最小雷达数目;例如这组数据;
3 2
0 0
1 2
4 0
我们用一个结构体 数组len【i】.right,len【i】.left分别记录当前的区间端点,然后将第一个岛屿的
len【i】.rigth与其后面的岛屿的雷达放置区间左端点一个的去对比(如果遇到有一个岛屿k的雷达放置区的右端点比其还小就要将right的
值更新到len【k】.right)直到遇到一个岛屿的雷达放置区的左端点不在其范围内就将数据更新到这个岛屿的雷达区间范围此时ans要+1;


PS:题目中数据有出现r<=0,直接输出Case #: -1即可

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<stdlib.h>
using namespace std;
struct Class{
    double x;
    double y;
}zb[1005];

struct Std{
    double s;
    double e;
}len[1005];
double r;
int ans,n;
bool cmp(Class a,Class b)
{
    return a.x<b.x;
}

void worklen()//将每个岛屿各自对应的能够放雷达的区域计算出来
{
    for(int i=0;i<n;i++)
    {
        /*cout<<len[i].s<<" "<<len[i].e<<endl;*/
        len[i].s=zb[i].x-sqrt(r*r-(zb[i].y*zb[i].y));
        len[i].e=zb[i].x+sqrt(r*r-(zb[i].y*zb[i].y));

    }
}
void work()
{
    int j;
    int l=0;

          for(j=1;j<n;j++)
             {
                 if(len[j].e<len[l].e)
                 {
                     l=j;//当有第j个岛屿雷达的放置区比l个岛屿的小时 注意要把最小的作为比较标准
                 }
                 else if(len[l].e<len[j].s)
                     {
                        ans++;
                        l=j;
                     }

             }

        return ;
}

int main()
{
    int i,flag,t=1;
    while(cin>>n>>r,n||r)
    {

        flag=0;
        ans=1;
        for(i=0;i<n;i++)
          cin>>zb[i].x>>zb[i].y;

            for(i=0;i<n;i++)
                if(fabs(zb[i].y)>r)
                   {
                       flag=1;
                   }
        if(flag)
            {
                cout<<"Case "<<t<<": "<<"-1"<<endl;
                t++;
            }
        else
        {
            sort(zb,zb+n,cmp);
            /*for(i=0;i<n;i++)
                cout<<zb[i].x<<" "<<zb[i].y<<endl;*/
            worklen();
            work();
            cout<<"Case "<<t<<": "<<ans<<endl;
            t++;

        }

    }

    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值