UVA 699 The Falling Leaves (二叉树水题)

本文纯属原创,转载请注明出处,谢谢。http://blog.csdn.net/zip_fan。

Description

Download as PDF

Each year, fall in the North Central region is accompanied by the brilliant colors of the leaves on the trees, followed quickly by the falling leaves accumulating under the trees. If the same thing happened to binary trees, how large would the piles of leaves become?


We assume each node in a binary tree "drops" a number of leaves equal to the integer value stored in that node. We also assume that these leaves drop vertically to the ground (thankfully, there's no wind to blow them around). Finally, we assume that the nodes are positioned horizontally in such a manner that the left and right children of a node are exactly one unit to the left and one unit to the right, respectively, of their parent. Consider the following tree:

The nodes containing 5 and 6 have the same horizontal position (with different vertical positions, of course). The node containing 7 is one unit to the left of those containing 5 and 6, and the node containing 3 is one unit to their right. When the "leaves" drop from these nodes, three piles are created: the leftmost one contains 7 leaves (from the leftmost node), the next contains 11 (from the nodes containing 5 and 6), and the rightmost pile contains 3. (While it is true that only leaf nodes in a tree would logically have leaves, we ignore that in this problem.)

Input 

The input contains multiple test cases, each describing a single tree. A tree is specified by giving the value in the root node, followed by the description of the left subtree, and then the description of the right subtree. If a subtree is empty, the value  -1 is supplied. Thus the tree shown above is specified as  5 7 -1 6 -1 -1 3 -1 -1. Each actual tree node contains a positive, non-zero value. The last test case is followed by a single  -1 (which would otherwise represent an empty tree).

Output 

For each test case, display the case number (they are numbered sequentially, starting with 1) on a line by itself. On the next line display the number of "leaves" in each pile, from left to right, with a single space separating each value. This display must start in column 1, and will not exceed the width of an 80-character line. Follow the output for each case by a blank line. This format is illustrated in the examples below.

Sample Input 

5 7 -1 6 -1 -1 3 -1 -1
8 2 9 -1 -1 6 5 -1 -1 12 -1
-1 3 7 -1 -1 -1
-1

Sample Output 

Case 1:
7 11 3

Case 2:
9 7 21 15



非常水的一道题,只是觉得模型非常棒所以积累下来。

题意是给你一颗二叉树,左儿子会比父节点左移一列,右儿子右移一列,求每列上的节点的值的和。

直接从根节点开始模拟列数,根本不需要建树,读入完毕的同时统计也完毕。

下面贴代码。


#include <cstdio>
#include <cmath>
#include <cstring>
#include <string>
#include <map>
#include <queue>
#include <vector>
#include <iostream>
#include <algorithm>
#define moo 1000000007//10^9+7
#define PI acos(-1.0)
#define eps 1e-5
using namespace std;
int ans[10000];
void cal(int sit)
{
    int x;
    scanf("%d",&x);
    if(x==-1)
        return;
    ans[sit]+=x;
    cal(sit-1);//统计左儿子
    cal(sit+1);//统计右儿子
}
int main()
{
    int n,ca=1;
    while(scanf("%d",&n)!=EOF&&n!=-1)
    {
        printf("Case %d:\n",ca++);
        memset(ans,0,sizeof(ans));
        ans[5555]=n;//因为不知道左边有多少项所以设定一个比较靠中间的值作为根节点在的列。
        cal(5554);cal(5556);
        int now=0;
        while(ans[now]==0)//去除前导零
            now++;
        int flag=0;
        for(int i=now;ans[i]!=0;flag=1,i++)
            printf((flag==0?"%d":" %d"),ans[i]);
        printf("\n\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值