算法——递归篇——树叶下落问题

     

UVa 699The Falling Leaves 

Each year, fall in the North Central region is accompanied by the brilliant colors of the leaves on the trees, followed quickly by the falling leaves accumulating under the trees. If the same thing happened to binary trees, how large would the piles of leaves become?


We assume each node in a binary tree "drops" a number of leaves equal to the integer value stored in that node. We also assume that these leaves drop vertically to the ground (thankfully, there's no wind to blow them around). Finally, we assume that the nodes are positioned horizontally in such a manner that the left and right children of a node are exactly one unit to the left and one unit to the right, respectively, of their parent. Consider the following tree:

                                                                699 <wbr>- <wbr>The <wbr>Falling <wbr>Leaves

 


The nodes containing 5 and 6 have the same horizontal position (with different vertical positions, of course). The node containing 7 is one unit to the left of those containing 5 and 6, and the node containing 3 is one unit to their right. When the "leaves" drop from these nodes, three piles are created: the leftmost one contains 7 leaves (from the leftmost node), the next contains 11 (from the nodes containing 5 and 6), and the rightmost pile contains 3. (While it is true that only leaf nodes in a tree would logically have leaves, we ignore that in this problem.)
 
Input 
The input contains multiple test cases, each describing a single tree. A tree is specified by giving the value in the root node, followed by the description of the left subtree, and then the description of the right subtree. If a subtree is empty, the value -1 is supplied. Thus the tree shown above is specified as 5 7 -1 6 -1 -1 3 -1 -1. Each actual tree node contains a positive, non-zero value. The last test case is followed by a single -1 (which would otherwise represent an empty tree).
 
Output 
For each test case, display the case number (they are numbered sequentially, starting with 1) on a line by itself. On the next line display the number of "leaves" in each pile, from left to right, with a single space separating each value. This display must start in column 1, and will not exceed the width of an 80-character line. Follow the output for each case by a blank line. This format is illustrated in the examples below.
 
Sample Input 
 

 5 7 -1 6 -1 -1 3 -1 -1

 8 2 9 -1 -1 6 5 -1 -1 12 -1 -1 3 7 -1 -1 -1 -1

 
Sample Output 

Case 1: 7 11 3 

Case 2: 9 7 21 15


题目的意思是让我们从左到右输出树叶下落的数量

举例说明一下:

 8 2 9 -1 -1 6 5 -1 -1 12 -1 -1 3 7 -1 -1 -1 -1

二叉树结构为:

                       

如上图所示,右边的图是修改后的,从垂直方向上看,依次是,9,2+5,8+6+7,3+12,这种结构就是我们想要的答案。

其实一开始想到的是怎么建立二叉树,然后在进行一系列复杂的处理,说实话,这个题真没有想到有这么巧妙的技巧,直接采用先序遍历的方式,先对头结点做处理.考虑到题目中的意思数组长度最长为80,一开始,我们从下标为40的执行,array[40]=8,然后递归执行左子树,接着是右子树。整体思路是这样,执行左子树的时候,传入的下标-1,判断当前左子树的头结点的值,然后继续递归调用其左右子树。。。

代码如下:

package hello.ant;

import java.util.Scanner;

public class AlogLeaves {
	static Scanner scanner=new Scanner(System.in);
	public static void main(String[] args) {
		int array[]=new int[80];
		findLeaves(array,40);
		displayArray(array);
	}

	static void displayArray(int[] array) {
		for(int i=0;i<array.length;i++){
			if(array[i]!=0){
				System.out.print(array[i]+"  ");
			}
		}
		System.out.println();
	}

	static void findLeaves(int[] array, int index) {
		int x=scanner.nextInt();
		if(x!=-1){
			array[index]+=x;
			findLeaves(array, index-1);
			findLeaves(array, index+1);
		}
	}
}

结果:

8 2 9 -1 -1 6 5 -1 -1 12 -1 -1 3 7 -1 -1 -1
9  7  21  15  


5 7 -1 6 -1 -1 3 -1 -1
7  11  3  


本文参考了这篇文章,http://blog.csdn.net/frankiller/article/details/7765929

深深体会到,这种技巧真不好把握。。。


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值