Matrix - POJ 2155 二维树状数组

Matrix
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 17150 Accepted: 6444

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 

There is a blank line between every two continuous test cases. 

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

题意:二维树状数组的区间更新,单点查询。

思路:对于每次更新,进行如下四个操作update(x2+1,y2+1,1);  update(x1,y2+1,-1);  update(x2+1,y1,-1);  update(x1,y1,1)。


AC代码如下:

#include<cstdio>
#include<cstring>
using namespace std;
int a[1010][1010];
char s[100];
int n,m;
int lowbit(int x)
{ return x&(-x);
}
void update(int x,int y,int val)
{ for(int Y=y;Y<=n;Y+=lowbit(Y))
   for(int X=x;X<=n;X+=lowbit(X))
    a[Y][X]+=val;
}
int sum(int x,int y)
{ int ret=0;
  for(int Y=y;Y>0;Y-=lowbit(Y))
   for(int X=x;X>0;X-=lowbit(X))
    ret+=a[Y][X];
  return ret;
}
int main()
{ int T,t,i,j,k,x1,y1,x2,y2,val;
  scanf("%d",&T);
  for(t=1;t<=T;t++)
  { if(t!=1)
     printf("\n");
    scanf("%d%d",&n,&m);
    memset(a,0,sizeof(a));
    while(m--)
    { scanf("%s",s);
      if(s[0]=='C')
      { scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
        update(x2+1,y2+1,1);
        update(x1,y2+1,-1);
        update(x2+1,y1,-1);
        update(x1,y1,1);
      }
      else
      { scanf("%d%d",&x1,&y1);
        val=sum(x1,y1);
        val%=2;
         printf("%d\n",val);
      }
    }
  }
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值