Feel Good - UVa 1619 dp

Bill is developing a new mathematical theory for human emotions. His recent investigations are dedicated to studying how good or bad days influent people's memories about some period of life.

A new idea Bill has recently developed assigns a non-negative integer value to each day of human life. Bill calls this value the emotional value of the day. The greater the emotional value is, the better the day was. Bill suggests that the value of some period of human life is proportional to the sum of the emotional values of the days in the given period, multiplied by the smallest emotional value of the day in it. This schema reflects that good on average period can be greatly spoiled by one very bad day.

Now Bill is planning to investigate his own life and find the period of his life that had the greatest value. Help him to do so.

Input 

The input will contain several test cases, each of them as described below. Consecutive test cases are separated by a single blank line.


The first line of the input file contains n - the number of days of Bill's life he is planning to investigate (1$ \le$n$ \le$100000) . The rest of the file contains n integer numbers a1a2,..., an ranging from 0 to 106 - the emotional values of the days. Numbers are separated by spaces and/or line breaks.

Output 

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.


On the first line of the output file print the greatest value of some period of Bill's life.

On the second line print two numbers l and r such that the period from l -th to r -th day of Bill's life (inclusive) has the greatest possible value. If there are multiple periods with the greatest possible value, then print the shortest one. If there are still several possibilities, print the one that occurs first..

Sample Input 

6 
3 1 6 4 5 2

Sample Output 

60 
3 5

题意:所求值为一段时间的总和乘以值最小的点,并输出时间范围,时间范围相同时,输出最早的。

思路:用l[i],r[i]记录第i天时的连续区间的最左端点和最右端点。具体看代码吧,还有注意0 0 0 0这组数据。

AC代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
long long sum[100010],l[100010],r[100010],value[100010],ans,x,y;
int main()
{ long long n,i,j,k,t=0;
  sum[0]=0;
  while(~scanf("%lld",&n))
  { ans=-1;
    for(i=1;i<=n;i++)
    { scanf("%lld",&value[i]);
      sum[i]=sum[i-1]+value[i];
      l[i]=i;r[i]=i;
    }
    value[0]=value[n+1]=-1;
    for(i=1;i<=n;i++)
     if(value[i]>0)
     while(value[l[i]-1]>=value[i])
      l[i]=l[l[i]-1];
    for(i=n;i>=1;i--)
     if(value[i]>0)
     while(value[r[i]+1]>=value[i])
      r[i]=r[r[i]+1];
    for(i=1;i<=n;i++)
    { k=value[i]*(sum[r[i]]-sum[l[i]-1]);
      if(k>ans)
      { ans=value[i]*(sum[r[i]]-sum[l[i]-1]);
        x=l[i];y=r[i];
      }
      else if(k==ans)
      { if(r[i]-l[i]<y-x)
        { x=l[i];y=r[i];}
        else if(r[i]-l[i]==y-x && l[i]<x)
        { x=l[i];y=r[i];}
      }
    }
    if(t!=0)
     printf("\n");
    t++;
    printf("%lld\n%lld %lld\n",ans,x,y);
  }
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值