Railroad - HDU 3779 dp

Railroad

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 494    Accepted Submission(s): 195


Problem Description
A train yard is a complex series of railroad tracks for storing, sorting, or loading/unloading railroad cars. In this problem, the railroad tracks are much simpler, and we are only interested in combining two trains into one.

Figure 1: Merging railroad tracks.


The two trains each contain some railroad cars. Each railroad car contains a single type of products identified by a positive integer up to 1,000,000. The two trains come in from the right on separate tracks, as in the diagram above. To combine the two trains, we may choose to take the railroad car at the front of either train and attach it to the back of the train being formed on the left. Of course, if we have already moved all the railroad cars from one train, then all remaining cars from the other train will be moved to the left one at a time. All railroad cars must be moved to the left eventually. Depending on which train on the right is selected at each step, we will obtain different arrangements for the departing train on the left. For example, we may obtain the order 1,1,1,2,2,2 by always choosing the top train until all of its cars have been moved. We may also obtain the order 2,1,2,1,2,1 by alternately choosing railroad cars from the two trains.

To facilitate further processing at the other train yards later on in the trip (and also at the destination), the supervisor at the train yard has been given an ordering of the products desired for the departing train. In this problem, you must decide whether it is possible to obtain the desired ordering, given the orders of the products for the two trains arriving at the train yard.
 

Input
The input consists of a number of cases. The first line contains two positive integers N 1 N 2 which are the number of railroad cars in each train. There are at least 1 and at most 1000 railroad cars in each train. The second line contains N1 positive integers (up to 1,000,000) identifying the products on the first train from front of the train to the back of the train. The third line contains N 2 positive integers identifying the products on the second train (same format as above). Finally, the fourth line contains N 1+N 2 positive integers giving the desired order for the departing train (same format as above).

The end of input is indicated by N 1 = N 2 = 0.
 

Output
For each case, print on a line  possible if it is possible to produce the desired order, or  not possible if not.
 

Sample Input
  
  
3 3 1 2 1 2 1 1 1 2 1 1 2 1 3 3 1 2 1 2 1 2 1 1 1 2 2 2 0 0
 

Sample Output
  
  
possible not possible
 

题意:问第一行和第二行合并能不能形成第三行。

思路:dp[i][j]表示第一行用前i个,第二行用前j个能不能形成第三行的前i+j个。

AC代码如下:

#include<cstdio>
#include<cstring>
using namespace std;
int num1[1010],num2[1010],num3[2010],dp[1010][1010];
int main()
{ int len1,len2,i,j,k;
  while(~scanf("%d%d",&len1,&len2) && len1)
  { for(i=1;i<=len1;i++)
     scanf("%d",&num1[i]);
    for(i=1;i<=len2;i++)
     scanf("%d",&num2[i]);
    for(i=1;i<=len1+len2;i++)
     scanf("%d",&num3[i]);
    memset(dp,0,sizeof(dp));
    dp[0][0]=1;
    for(i=0;i<=len1;i++)
     for(j=0;j<=len2;j++)
     { if(i==0 && j==0)
        continue;
       if(i>0 && num1[i]==num3[i+j] && dp[i-1][j]==1)
        dp[i][j]=1;
       if(j>0 && num2[j]==num3[i+j] && dp[i][j-1]==1)
        dp[i][j]=1;
     }
    if(dp[len1][len2]==1)
     printf("possible\n");
    else
     printf("not possible\n");
  }
}

外加一份dfs的AC代码:

#include<cstdio>
#include<cstring>
using namespace std;
int n,m,num1[1010],num2[1010],num3[2010],vis[1010][1010];
bool flag;
void dfs(int a,int b)
{ if(flag)
   return;
  if(vis[a][b]==1)
   return;
  if(a==n && b==m)
  { flag=true;
    return;
  }
  if(a<n && num1[a+1]==num3[a+b+1])
   dfs(a+1,b);
  if(b<m && num2[b+1]==num3[a+b+1])
   dfs(a,b+1);
   vis[a][b]=1;
}
int main()
{ int i,j,k;
  while(~scanf("%d%d",&n,&m) && n+m)
  { for(i=1;i<=n;i++)
     scanf("%d",&num1[i]);
    for(i=1;i<=m;i++)
     scanf("%d",&num2[i]);
     for(i=1;i<=n+m;i++)
     scanf("%d",&num3[i]);
     flag=false;
     memset(vis,0,sizeof(vis));
     dfs(0,0);
     if(flag)
      printf("possible\n");
     else
      printf("not possible\n");
  }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值