Railroad - HDU 3779 dp

Railroad

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 494    Accepted Submission(s): 195


Problem Description
A train yard is a complex series of railroad tracks for storing, sorting, or loading/unloading railroad cars. In this problem, the railroad tracks are much simpler, and we are only interested in combining two trains into one.

Figure 1: Merging railroad tracks.


The two trains each contain some railroad cars. Each railroad car contains a single type of products identified by a positive integer up to 1,000,000. The two trains come in from the right on separate tracks, as in the diagram above. To combine the two trains, we may choose to take the railroad car at the front of either train and attach it to the back of the train being formed on the left. Of course, if we have already moved all the railroad cars from one train, then all remaining cars from the other train will be moved to the left one at a time. All railroad cars must be moved to the left eventually. Depending on which train on the right is selected at each step, we will obtain different arrangements for the departing train on the left. For example, we may obtain the order 1,1,1,2,2,2 by always choosing the top train until all of its cars have been moved. We may also obtain the order 2,1,2,1,2,1 by alternately choosing railroad cars from the two trains.

To facilitate further processing at the other train yards later on in the trip (and also at the destination), the supervisor at the train yard has been given an ordering of the products desired for the departing train. In this problem, you must decide whether it is possible to obtain the desired ordering, given the orders of the products for the two trains arriving at the train yard.
 

Input
The input consists of a number of cases. The first line contains two positive integers N 1 N 2 which are the number of railroad cars in each train. There are at least 1 and at most 1000 railroad cars in each train. The second line contains N1 positive integers (up to 1,000,000) identifying the products on the first train from front of the train to the back of the train. The third line contains N 2 positive integers identifying the products on the second train (same format as above). Finally, the fourth line contains N 1+N 2 positive integers giving the desired order for the departing train (same format as above).

The end of input is indicated by N 1 = N 2 = 0.
 

Output
For each case, print on a line  possible if it is possible to produce the desired order, or  not possible if not.
 

Sample Input
  
  
3 3 1 2 1 2 1 1 1 2 1 1 2 1 3 3 1 2 1 2 1 2 1 1 1 2 2 2 0 0
 

Sample Output
  
  
possible not possible
 

题意:问第一行和第二行合并能不能形成第三行。

思路:dp[i][j]表示第一行用前i个,第二行用前j个能不能形成第三行的前i+j个。

AC代码如下:

#include<cstdio>
#include<cstring>
using namespace std;
int num1[1010],num2[1010],num3[2010],dp[1010][1010];
int main()
{ int len1,len2,i,j,k;
  while(~scanf("%d%d",&len1,&len2) && len1)
  { for(i=1;i<=len1;i++)
     scanf("%d",&num1[i]);
    for(i=1;i<=len2;i++)
     scanf("%d",&num2[i]);
    for(i=1;i<=len1+len2;i++)
     scanf("%d",&num3[i]);
    memset(dp,0,sizeof(dp));
    dp[0][0]=1;
    for(i=0;i<=len1;i++)
     for(j=0;j<=len2;j++)
     { if(i==0 && j==0)
        continue;
       if(i>0 && num1[i]==num3[i+j] && dp[i-1][j]==1)
        dp[i][j]=1;
       if(j>0 && num2[j]==num3[i+j] && dp[i][j-1]==1)
        dp[i][j]=1;
     }
    if(dp[len1][len2]==1)
     printf("possible\n");
    else
     printf("not possible\n");
  }
}

外加一份dfs的AC代码:

#include<cstdio>
#include<cstring>
using namespace std;
int n,m,num1[1010],num2[1010],num3[2010],vis[1010][1010];
bool flag;
void dfs(int a,int b)
{ if(flag)
   return;
  if(vis[a][b]==1)
   return;
  if(a==n && b==m)
  { flag=true;
    return;
  }
  if(a<n && num1[a+1]==num3[a+b+1])
   dfs(a+1,b);
  if(b<m && num2[b+1]==num3[a+b+1])
   dfs(a,b+1);
   vis[a][b]=1;
}
int main()
{ int i,j,k;
  while(~scanf("%d%d",&n,&m) && n+m)
  { for(i=1;i<=n;i++)
     scanf("%d",&num1[i]);
    for(i=1;i<=m;i++)
     scanf("%d",&num2[i]);
     for(i=1;i<=n+m;i++)
     scanf("%d",&num3[i]);
     flag=false;
     memset(vis,0,sizeof(vis));
     dfs(0,0);
     if(flag)
      printf("possible\n");
     else
      printf("not possible\n");
  }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
代码下载:完整代码,可直接运行 ;运行版本:2022a或2019b或2014a;若运行有问题,可私信博主; **仿真咨询 1 各类智能优化算法改进及应用** 生产调度、经济调度、装配线调度、充电优化、车间调度、发车优化、水库调度、三维装箱、物流选址、货位优化、公交排班优化、充电桩布局优化、车间布局优化、集装箱船配载优化、水泵组合优化、解医疗资源分配优化、设施布局优化、可视域基站和无人机选址优化 **2 机器学习和深度学习方面** 卷积神经网络(CNN)、LSTM、支持向量机(SVM)、最小二乘支持向量机(LSSVM)、极限学习机(ELM)、核极限学习机(KELM)、BP、RBF、宽度学习、DBN、RF、RBF、DELM、XGBOOST、TCN实现风电预测、光伏预测、电池寿命预测、辐射源识别、交通流预测、负荷预测、股价预测、PM2.5浓度预测、电池健康状态预测、水体光学参数反演、NLOS信号识别、地铁停车精准预测、变压器故障诊断 **3 图像处理方面** 图像识别、图像分割、图像检测、图像隐藏、图像配准、图像拼接、图像融合、图像增强、图像压缩感知 **4 路径规划方面** 旅行商问题(TSP)、车辆路径问题(VRP、MVRP、CVRP、VRPTW等)、无人机三维路径规划、无人机协同、无人机编队、机器人路径规划、栅格地图路径规划、多式联运运输问题、车辆协同无人机路径规划、天线线性阵列分布优化、车间布局优化 **5 无人机应用方面** 无人机路径规划、无人机控制、无人机编队、无人机协同、无人机任务分配 **6 无线传感器定位及布局方面** 传感器部署优化、通信协议优化、路由优化、目标定位优化、Dv-Hop定位优化、Leach协议优化、WSN覆盖优化、组播优化、RSSI定位优化 **7 信号处理方面** 信号识别、信号加密、信号去噪、信号增强、雷达信号处理、信号水印嵌入提取、肌电信号、脑电信号、信号配时优化 **8 电力系统方面** 微电网优化、无功优化、配电网重构、储能配置 **9 元胞自动机方面** 交通流 人群疏散 病毒扩散 晶体生长 **10 雷达方面** 卡尔曼滤波跟踪、航迹关联、航迹融合

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值