Distinct Subsequences - UVa 10069 dp+高精度

Distinct Subsequences

Input: standard input

Output: standard output

 

A subsequence of a given sequence is just the given sequence with some elements (possibly none) left out. Formally, given a sequence X =x1x2xm, another sequence Z = z1z2zk is a subsequence of X if there exists a strictly increasing sequence <i1i2, …, ik> of indices of Xsuch that for all j = 1, 2, …, k, we have xij = zj. For example, Z = bcdb is a subsequence of X = abcbdab with corresponding index sequence< 2, 3, 5, 7 >.

In this problem your job is to write a program that counts the number of occurrences of Z in X as a subsequence such that each has a distinct index sequence.

 

Input

The first line of the input contains an integer N indicating the number of test cases to follow.

The first line of each test case contains a string X, composed entirely of lowercase alphabetic characters and having length no greater than 10,000. The second line contains another string Z having length no greater than 100 and also composed of only lowercase alphabetic characters. Be assured that neither Z nor any prefix or suffix of Z will have more than 10100 distinct occurrences in X as a subsequence.

 

Output

For each test case in the input output the number of distinct occurrences of Z in X as a subsequence. Output for each input set must be on a separate line.

 

Sample Input

2
babgbag
bag
rabbbit
rabbit

 

Sample Output

5
3


题意:第二个字符串在第一个字符串中一共有多少种组合方式。

思路:dp[i][j]表示第一个字符串前i位,匹配第二个字符串的前j位一共有多少种匹配方式。if(s1[i]==s2[j])   dp[i][j]=dp[i-1][j]+dp[i-1][j-1];    else    dp[i][j]=dp[i-1][j];

           然后此题答案比较大,要用到高精度……懒得打了,就用JAVA吧【其实你是不会打高精度→_→   人艰不拆啊

AC代码如下:

import java.math.BigInteger;
import java.util.Scanner;

public class Main
{ public static void main(String [] args)
  { Scanner scan=new Scanner(System.in);
	int t,i,j,k,len1,len2;
	String s1,s2;
    BigInteger dp[][]=new BigInteger[10010][110];
    
    for(i=0;i<=10000;i++)
     for(j=0;j<=100;j++)
      dp[i][j]=BigInteger.ZERO;
    for(i=0;i<=10000;i++)
   	 dp[i][0]=BigInteger.ONE;
    t=scan.nextInt();
    while(t>0)
    { t--;
      s1=scan.next();
      s2=scan.next();
      len1=s1.length();
      len2=s2.length();
      for(i=1;i<=len1;i++)
       for(j=1;j<=len2;j++)
       { if(s1.charAt(i-1)==s2.charAt(j-1))
    	  dp[i][j]=dp[i-1][j].add(dp[i-1][j-1]);
         else
    	  dp[i][j]=dp[i-1][j];
       }
      System.out.println(dp[len1][len2]);
    }
  }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值