A Spy in the Metro - UVa 1025 dp

Secret agent Maria was sent to Algorithms City to carry out an especially dangerous mission. After several thrilling events we find her in the first station of Algorithms City Metro, examining the time table. The Algorithms City Metro consists of a single line with trains running both ways, so its time table is not complicated.

Maria has an appointment with a local spy at the last station of Algorithms City Metro. Maria knows that a powerful organization is after her. She also knows that while waiting at a station, she is at great risk of being caught. To hide in a running train is much safer, so she decides to stay in running trains as much as possible, even if this means traveling backward and forward. Maria needs to know a schedule with minimal waiting time at the stations that gets her to the last station in time for her appointment. You must write a program that finds the total waiting time in a best schedule for Maria.

The Algorithms City Metro system has N stations, consecutively numbered from 1 to N. Trains move in both directions: from the first station to the last station and from the last station back to the first station. The time required for a train to travel between two consecutive stations is fixed since all trains move at the same speed. Trains make a very short stop at each station, which you can ignore for simplicity. Since she is a very fast agent, Maria can always change trains at a station even if the trains involved stop in that station at the same time.

\epsfbox{p2728.eps}

Input 

The input file contains several test cases. Each test case consists of seven lines with information as follows.
Line 1.
The integer  N (  2$ \le$N$ \le$50), which is the number of stations.
Line 2.
The integer  T (  0$ \le$T$ \le$200), which is the time of the appointment.
Line 3.
N - 1 integers:  t1t2,..., tN - 1 (  1$ \le$ti$ \le$70), representing the travel times for the trains between two consecutive stations:  t1 represents the travel time between the first two stations,  t2 the time between the second and the third station, and so on.
Line 4.
The integer  M1 (  1$ \le$M1$ \le$50), representing the number of trains departing from the first station.
Line 5.
M1 integers:  d1d2,..., dM1 (  0$ \le$di$ \le$250 and  di < di + 1), representing the times at which trains depart from the first station.
Line 6.
The integer  M2 (  1$ \le$M2$ \le$50), representing the number of trains departing from the  N-th station.
Line 7.
M2 integers:  e1e2,..., eM2 (  0$ \le$ei$ \le$250 and  ei < ei + 1) representing the times at which trains depart from the  N-th station.

The last case is followed by a line containing a single zero.

Output 

For each test case, print a line containing the case number (starting with 1) and an integer representing the total waiting time in the stations for a best schedule, or the word ` impossible ' in case Maria is unable to make the appointment. Use the format of the sample output.

Sample Input 

4
55
5 10 15
4
0 5 10 20
4
0 5 10 15
4
18
1 2 3
5
0 3 6 10 12
6
0 3 5 7 12 15
2
30
20
1
20
7
1 3 5 7 11 13 17
0

Sample Output 

Case Number 1: 5
Case Number 2: 0
Case Number 3: impossible

题意:一共有n个车站,你需要恰好在t时刻在第n个车站和别人碰头,期间你可以乘坐任意的车,有m1个车从左边发车,m2个车从右边发车,并且都告诉你发车时间。问你在车站等待的最少时间是多少。

思路:dp[i][j]表示你在i时间在第j个车站,每次你可以选择等一分钟,坐往左走的车,坐往右走的车(需要判断此时是否有这样的车)。

AC代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int num1[60],num2[60],dp[210][60],n,m1,m2,t,dis[60],INF=1000000000;
int main()
{ int i,j,k,p,T=0;
  while(~scanf("%d",&n) && n)
  { scanf("%d",&t);
    for(i=2;i<=n;i++)
    { scanf("%d",&dis[i]);
      dis[i]+=dis[i-1];
    }
    scanf("%d",&m1);
    for(i=1;i<=m1;i++)
     scanf("%d",&num1[i]);
    scanf("%d",&m2);
    for(i=1;i<=m2;i++)
     scanf("%d",&num2[i]);
    for(i=0;i<=t;i++)
     for(j=0;j<=n;j++)
      dp[i][j]=INF;
    dp[0][1]=0;
    for(i=0;i<t;i++)
     for(j=1;j<=n;j++)
     { if(dp[i][j]==INF)
        continue;
       dp[i+1][j]=min(dp[i+1][j],dp[i][j]+1);
       for(k=1;k<=m1;k++)
        if(num1[k]+dis[j]==i)
        { for(p=j+1;j<=n && i+dis[p]-dis[j]<=t;p++)
           dp[i+dis[p]-dis[j]][p]=min(dp[i+dis[p]-dis[j]][p],dp[i][j]);
        }
       for(k=1;k<=m2;k++)
        if(num2[k]+dis[n]-dis[j]==i)
        { for(p=j-1;p>=1 && i+dis[j]-dis[p]<=t;p--)
           dp[i+dis[j]-dis[p]][p]=min(dp[i+dis[j]-dis[p]][p],dp[i][j]);
        }
     }
    if(dp[t][n]==INF)
     printf("Case Number %d: impossible\n",++T);
    else
     printf("Case Number %d: %d\n",++T,dp[t][n]);
  }
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值