Atomic Car Race - POJ 2744 dp

Atomic Car Race
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1194 Accepted: 578 Special Judge

Description

In the year 2020, a race of atomically energized cars will be held. Unlike today's car races, fueling is not a concern of racing teams. Cars can run throughout the course without any refueling. Instead, the critical factor is tire (tyre). Teams should carefully plan where to change tires of their cars. 
The race is a road race having n checkpoints in the course. Their distances from the start are a1, a2, ..., and an (in kilometers). The n-th checkpoint is the goal. At the i-th checkpoint (i < n), tires of a car can be changed. Of course, a team can choose whether to change or not to change tires at each checkpoint. It takes b seconds to change tires (including overhead for braking and accelerating). There is no time loss at a checkpoint if a team chooses not to change tires. 
A car cannot run fast for a while after a tire change, because the temperature of tires is lower than the designed optimum. After running long without any tire changes, on the other hand, a car cannot run fast because worn tires cannot grip the road surface well. The time to run an interval of one kilometer from x to x + 1 is given by the following expression (in seconds). Here x is a nonnegative integer denoting the distance (in kilometers) from the latest checkpoint where tires are changed (or the start). r, v, e and f are given constants. 
  • 1/(v - e * (x - r)) (if x >= r) 
    1/(v - f * (r - x)) (if x < r)

Your mission is to write a program to determine the best strategy of tire changes which minimizes the total time to the goal.

Input

The input consists of multiple datasets each corresponding to a race situation. The format of a 
dataset is as follows. 

a1 a2 . . . an 

r v e f 
The meaning of each of the input items is given in the problem statement. If an input line contains two or more input items, they are separated by a space. 
n is a positive integer not exceeding 100. Each of a1, a2, ..., and an is a positive integer satisfying 0 < a1 < a2 < . . . < an <= 10000. b is a positive decimal fraction not exceeding 100.0. r is a nonnegative integer satisfying 0 <= r <= an - 1. Each of v, e and f is a positive decimal fraction. You can assume that v - e * (an - 1 - r) >= 0.01 and v - f * r >= 0.01. 
The end of the input is indicated by a line with a single zero.

Output

For each dataset in the input, one line containing a decimal fraction should be output. The decimal fraction should give the elapsed time at the goal (in seconds) when the best strategy is taken. An output line should not contain extra characters such as spaces. 
The answer should not have an error greater than 0.001. You may output any number of digits after the decimal point, provided that the above accuracy condition is satisfied.

Sample Input

2
2 3
1.0
1 1.0 0.1 0.3
5
5 10 15 20 25
0.15
1 1.0 0.04 0.5
10
1783 3640 3991 4623 5465 5481 6369 6533 6865 8425
4.172
72 59.4705 0.0052834 0.0611224
0

Sample Output

3.5397
31.9249
168.6682

题意:有n个换轮胎的服务点,一个新的轮胎从x到x+1需要的时间如公式所示,问到终点最短时间是多少。

思路:dp[i]表示在到达第i个站台需要的时间。

AC代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
double dp[110],cost[10010];
int dis[110],INF=1e9+7;
int main()
{
    int n,m,i,j,k,r;
    double d,b,v,e,f,ret;
    while(~scanf("%d",&n) && n)
    {
        for(i=1;i<=n;i++)
           scanf("%d",&dis[i]);
        scanf("%lf%d%lf%lf%lf",&d,&r,&v,&e,&f);
        for(i=0;i<dis[n];i++)
        {
            if(i<r)
              ret=1.0/(v-f*(r-i));
            else
              ret=1.0/(v-e*(i-r));
            if(i==0)
              cost[i]=ret;
            else
              cost[i]=cost[i-1]+ret;
        }
        for(i=1;i<=n;i++)
           dp[i]=INF;
        dp[0]=0;
        for(i=0;i<n;i++)
        {
            if(i==0)
              ret=0;
            else
              ret=d;
            for(j=i+1;j<=n;j++)
               dp[j]=min(dp[j],dp[i]+cost[dis[j]-dis[i]-1]+ret);
        }
        printf("%.4f\n",dp[n]);
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值