Tree Cutting - POJ 2378 树形dp

Tree Cutting
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3727 Accepted: 2222

Description

After Farmer John realized that Bessie had installed a "tree-shaped" network among his N (1 <= N <= 10,000) barns at an incredible cost, he sued Bessie to mitigate his losses. 

Bessie, feeling vindictive, decided to sabotage Farmer John's network by cutting power to one of the barns (thereby disrupting all the connections involving that barn). When Bessie does this, it breaks the network into smaller pieces, each of which retains full connectivity within itself. In order to be as disruptive as possible, Bessie wants to make sure that each of these pieces connects together no more than half the barns on FJ. 

Please help Bessie determine all of the barns that would be suitable to disconnect.

Input

* Line 1: A single integer, N. The barns are numbered 1..N. 

* Lines 2..N: Each line contains two integers X and Y and represents a connection between barns X and Y.

Output

* Lines 1..?: Each line contains a single integer, the number (from 1..N) of a barn whose removal splits the network into pieces each having at most half the original number of barns. Output the barns in increasing numerical order. If there are no suitable barns, the output should be a single line containing the word "NONE".

Sample Input

10
1 2
2 3
3 4
4 5
6 7
7 8
8 9
9 10
3 8

Sample Output

3
8

Hint

INPUT DETAILS: 

The set of connections in the input describes a "tree": it connects all the barns together and contains no cycles. 

OUTPUT DETAILS: 

If barn 3 or barn 8 is removed, then the remaining network will have one piece consisting of 5 barns and two pieces containing 2 barns. If any other barn is removed then at least one of the remaining pieces has size at least 6 (which is more than half of the original number of barns, 5).

题意:一个树中删去一个节点,若其他的树的节点数均不超过n/2,这个节点就可以作为一个答案。

思路:dfs,没什么好说的。

AC代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
using namespace std;
int n,ans[10010],num[10010];
vector<int> vc[10010];
void dfs(int f,int u)
{
    int i,j,k,v,len=vc[u].size();
    bool flag=true;
    for(i=0;i<len;i++)
    {
        v=vc[u][i];
        if(v==f)
          continue;
        dfs(u,v);
        num[u]+=num[v];
        if(num[v]>n/2)
          flag=false;
    }
    if(n-num[u]>n/2)
      flag=false;
    if(flag)
    {
        ans[0]++;
        ans[ans[0]]=u;
    }
}
int main()
{
    int i,j,k,u,v;
    scanf("%d",&n);
    for(i=1;i<n;i++)
    {
        scanf("%d%d",&u,&v);
        vc[u].push_back(v);
        vc[v].push_back(u);
    }
    for(i=1;i<=n;i++)
       num[i]=1;
    dfs(0,1);
    if(ans[0]==0)
      printf("NONE\n");
    else
    {
        sort(ans+1,ans+1+ans[0]);
        for(i=1;i<=ans[0];i++)
           printf("%d\n",ans[i]);
    }
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值