Garlands - UVa 1443 二分+dp

Garland decorator is a profession which recently gained in importance, especially during Christmas time. Any kid can decorate a christmas tree, any parent can put gifts in sockets, and even anyone can start believing in Santa Claus, but hanging christmas garlands is a completely difflerent story. As you will learn, it is an extremely important, responsible and tough job.

A garland consists of n pieces of equal length. Due to decorations like christmas balls attached to garlands, piece i has its own weight wi. The garland has to be attached to the ceiling in m spots, where the very beginning of the garland should be attached to spot 1 and its end to spot m. The garland should also be hooked to the remaining spots, which divides it into segments, each consisting of several consecutive pieces. There are, however, several rules that every respectable garland decorator should keep in mind.


(i)
Each segment should contain a positive even number of pieces. Due to this condition, we may divide a segment into two  half-segments.
(ii)
To minimize the chance that a guest hits your precious garland with their head (and tears it into pieces), the garland cannot hang too low: each half-segment can contain at most  d pieces.
(iii)
Finally, to keep the ceiling from falling on people heads, the decorator should minimize the weight of the heaviest half-segment.


An example of an optimally hanging garland (consisting of twelve pieces in three segments) is presented below; weights of respective pieces are given in circles.

\epsfbox{p4625.eps}

Input 

The input contains several test cases. The first line of the input contains a positive integer  Z$ \le$50 , denoting the number of test cases. Then  Z  test cases follow, each conforming to the format described below.


The description of each garland consists of two lines. The first line describing a particular garland contains three positive integers nm, and d (1$ \le$n$ \le$40000, 2$ \le$m$ \le$10000, 1$ \le$d$ \le$10000) separated by single spaces and described above. The second line contains n positive integers w1w2,..., wn (1$ \le$wi$ \le$10000), being the weights of the corresponding pieces.

Output 

For each test case, your program has to write an output conforming to the format described below.


For each garland, your program should output a single line containing one integer, being the weight of the heaviest half-segment in an optimal attachment of the garland. If it is not possible to hang the garland satisfying conditions (i) and (ii), then your program should output word `BAD'.

Sample Input 

4 
4 3 10 
10 10 20 20 
6 4 10 
1 1 100 100 1 1 
6 3 10 
1 1 100 100 1 1 
1 2 2 
333

Sample Output 

20 
100 
200 
BAD

题意:将一个长度为n的灯分成m-1段,每段必须是偶数个,且每半段的数量不超过d,问每半段的重量和的最大值的最小值。

思路:先排除不可能的情况,然后二分这个重量的答案,用dp进行验证,dp[i]表示前i的灯至少需要分多少段,同时dp[i][0,1]区分奇数和偶数。

AC代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;
typedef long long ll;
ll val[40010],sum[40010];
int n,n2,m,d,dp[20010][2],INF=1e9;
bool check(ll maxn)
{
    int i,j;
    dp[0][0]=0;
    dp[0][1]=INF;
    for(i=1;i<=n2;i++)
    {
        dp[i][0]=INF;
        dp[i][1]=INF;
        for(j=i-1;j>=0 && i-j<=d;j--)
        {
            if(sum[i*2]-sum[i+j]>maxn)
             break;
            if(sum[i+j]-sum[j*2]<=maxn)
            {
                dp[i][0]=min(dp[i][0],dp[j][1]+1);
                dp[i][1]=min(dp[i][1],dp[j][0]+1);
            }
        }
    }
    if(dp[n2][m%2]<=m)
      return true;
    else
      return false;
}
int main()
{
    int T,t,i,j,k,a,b,len;
    ll l,r,mi;
    scanf("%d",&T);
    for(t=1;t<=T;t++)
    {
        scanf("%d%d%d",&n,&m,&d);
        for(i=1;i<=n;i++)
        {
            scanf("%lld",&val[i]);
            sum[i]=sum[i-1]+val[i];
        }
        if(m==1 || n&1 || n<2*(m-1) || n>(m-1)*d*2)
        {
            printf("BAD\n");
            continue;
        }
        n2=n/2;
        m--;
        l=1;r=sum[n];
        while(l<r)
        {
            mi=(l+r)/2;
            if(check(mi))
              r=mi;
            else
              l=mi+1;
        }
        printf("%lld\n",l);
    }
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值