Brownie Points II - POJ 2464 线段树

Brownie Points II
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 1987 Accepted: 704

Description

Stan and Ollie play the game of Odd Brownie Points. Some brownie points are located in the plane, at integer coordinates. Stan plays first and places a vertical line in the plane. The line must go through a brownie point and may cross many (with the same x-coordinate). Then Ollie places a horizontal line that must cross a brownie point already crossed by the vertical line. 
Those lines divide the plane into four quadrants. The quadrant containing points with arbitrarily large positive coordinates is the top-right quadrant. 

The players score according to the number of brownie points in the quadrants. If a brownie point is crossed by a line, it doesn't count. Stan gets a point for each (uncrossed) brownie point in the top-right and bottom-left quadrants. Ollie gets a point for each (uncrossed) brownie point in the top-left and bottom-right quadrants. 

Stan and Ollie each try to maximize his own score. When Stan plays, he considers the responses, and chooses a line which maximizes his smallest-possible score.

Input

Input contains a number of test cases. The data of each test case appear on a sequence of input lines. The first line of each test case contains a positive odd integer 1 < n < 200000 which is the number of brownie points. Each of the following n lines contains two integers, the horizontal (x) and vertical (y) coordinates of a brownie point. No two brownie points occupy the same place. The input ends with a line containing 0 (instead of the n of a test).

Output

For each input test, print a line of output in the format shown below. The first number is the largest score which Stan can assure for himself. The remaining numbers are the possible (high) scores of Ollie, in increasing order.

Sample Input

11
3 2
3 3
3 4
3 6
2 -2
1 -3
0 0
-3 -3
-3 -2
-3 -4
3 -7
0

Sample Output

Stan: 7; Ollie: 2 3;

题意:第一个人先选一个列,要求这个列包含点,第二个人在这个列上再选一个行,要求包含这个列上的某个点,最后一三象限的点是第一个人的得分,二四象限的点是第二个人的得分。第一个人会使自己可能的最小值最大,第二个人使自己的得分最大。问第一个人的最小的分的最大值,和在此情况下第二个人可能的得分。

思路:对于每个点,只要找出以它为中心对于两个人的得分即可,这个用线段树,先考虑第三象限的,再重建树做第一象限的,有了第一个人的得分,就可以推出第二个人的得分了,最后进行统计计算。

AC代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<map>
using namespace std;
struct node1
{
    int x,y,ny,nx;
}point[200010];
struct node2
{
    int l,r,num;
}tree[800010];
int num[200010],num2[200010],ans[200010],p[200010],nx[200010],ny[200010];
map<int,int> match3;
bool cmp1(node1 a,node1 b)
{
    if(a.x==b.x)
      return a.y>b.y;
    return a.x<b.x;
}
bool cmp2(node1 a,node1 b)
{
    return a.y>b.y;
}
void build(int o,int l,int r)
{
    tree[o].l=l;
    tree[o].r=r;
    tree[o].num=0;
    if(l==r)
      return;
    int mi=(l+r)/2;
    build(o<<1,l,mi);
    build(o<<1|1,mi+1,r);
}
void update(int o,int l)
{
    if(tree[o].l==tree[o].r)
    {
        tree[o].num++;
        return;
    }
    int mi=(tree[o].l+tree[o].r)/2;
    if(l<=mi)
      update(o<<1,l);
    else
      update(o<<1|1,l);
    tree[o].num=tree[o<<1].num+tree[o<<1|1].num;
}
int query(int o,int l,int r)
{
    if(tree[o].l==l && tree[o].r==r)
      return tree[o].num;
    int mi=(tree[o].l+tree[o].r)/2;
    if(r<=mi)
      return query(o<<1,l,r);
    else if(l>mi)
      return query(o<<1|1,l,r);
    else
      return query(o<<1,l,mi)+query(o<<1|1,mi+1,r);
}
int main()
{
    int n,m,i,j,k,pos,a,b,maxa,pre,q;
    while(~scanf("%d",&n) && n>0)
    {
        match3.clear();
        for(i=1;i<=n;i++)
           num[i]=0;
        for(i=1;i<=n;i++)
           scanf("%d%d",&point[i].x,&point[i].y);
        sort(point+1,point+1+n,cmp2);

        match3[point[1].y]=1;
        m=1;
        for(i=2;i<=n;i++)
           if(point[i].y!=point[i-1].y)
             match3[point[i].y]=++m;

        pre=0;q=1;point[n+1].y=point[n].y+10;
        for(i=1;i<=n;i++)
        {
            point[i].ny=q;
            if(point[i].y!=point[i+1].y)
            {
                ny[q]=i-pre;
                pre=i;
                q++;
            }
        }
        sort(point+1,point+1+n,cmp1);

        pre=0;q=1;point[n+1].x=point[n].x+10;
        for(i=1;i<=n;i++)
        {
            point[i].nx=q;
            if(point[i].x!=point[i+1].x)
            {
                nx[q]=i-pre;
                pre=i;
                q++;
            }
        }

        build(1,1,m);
        for(i=1;i<=n;i++)
        {
            pos=p[i]=match3[point[i].y];
            if(pos<m)
            num[i]+=query(1,pos+1,m);
            update(1,pos);
        }
        build(1,1,m);
        for(i=n;i>=1;i--)
        {
            pos=p[i];
            if(pos>1)
              num[i]+=query(1,1,pos-1);
            update(1,pos);
        }
        for(i=1;i<=n;i++)
           num2[i]=n-nx[point[i].nx]-ny[point[i].ny]+1-num[i];
        point[n+1].x=point[n].x+1;
        a=-1;b=-1;maxa=-1;
        for(i=1;i<=n;i++)
        {
            if(num2[i]>b)
            {
                b=num2[i];
                a=num[i];
            }
            else if(num2[i]==b)
              a=min(a,num[i]);
            if(point[i].x!=point[i+1].x)
            {
                if(a>maxa)
                {
                    maxa=a;
                    ans[0]=1;
                    ans[1]=b;
                }
                else if(a==maxa)
                  ans[++ans[0]]=b;
                a=b=-1;
            }
        }
        sort(ans+1,ans+1+ans[0]);
        printf("Stan: %d; Ollie: %d",maxa,ans[1]);
        for(i=2;i<=ans[0];i++)
           if(ans[i]!=ans[i-1])
             printf(" %d",ans[i]);
        printf(";\n");
    }
}



Brownie 是一个 Python 框架和开发工具,旨在简化以太坊基础设施的开发和部署。它使用了许多现有的 Python 库,如 Web3py 和 Solidity 来为以太坊开发提供一个友好的环境。 下面是一些 Brownie 工具的详细介绍: 1. 命令行界面 (CLI):Brownie 提供了一个命令行界面,可以方便地管理和部署以太坊智能合约。CLI 支持 Solidity 编译、测试、部署和交互式调试以及其他常见的任务。 2. 项目管理器:Brownie 提供一个项目管理器,可以帮助您组织和管理多个智能合约项目。项目管理器可以自动创建项目结构,包括测试和部署文件夹,并为您的项目创建默认的配置文件。 3. 测试工具:Brownie 提供一组测试工具,包括自动化测试框架和测试覆盖率分析工具。测试工具可以帮助您确保您的智能合约代码质量,并且可以帮助您发现潜在的漏洞和安全问题。 4. 部署工具:Brownie 提供了一组部署工具,可以帮助您部署和管理以太坊智能合约。部署工具可以自动化合约部署,并且可以与常见的以太坊网络(如测试网络和主网络)进行交互。 5. 交互式环境:Brownie 提供一个交互式环境,可以让您方便地与以太坊网络进行交互。您可以使用交互式环境来测试和调试智能合约代码,也可以使用它来执行常见的以太坊任务,如查询余额和交易状态。 总之,如果您正在开发以太坊智能合约,那么 Brownie 工具可以帮助您更轻松地管理和部署您的项目,并提供一组有用的工具来确保您的代码质量和安全性。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值