Lift Hopping - UVa 10801 Floyd

76 篇文章 0 订阅

Lift Hopping
Time Limit: 1 second

Ted the bellhop: "I'm coming up and if there isn't
a dead body by the time I get there, I'll make one
myself. You!"

Robert Rodriguez, "Four Rooms."

A skyscraper has no more than 100 floors, numbered from 0 to 99. It has n (1<=n<=5) elevators which travel up and down at (possibly) different speeds. For each i in {1, 2,... n}, elevator number i takes Ti (1<=Ti<=100) seconds to travel between any two adjacent floors (going up or down). Elevators do not necessarily stop at every floor. What's worse, not every floor is necessarily accessible by an elevator.

You are on floor 0 and would like to get to floor k as quickly as possible. Assume that you do not need to wait to board the first elevator you step into and (for simplicity) the operation of switching an elevator on some floor always takes exactly a minute. Of course, both elevators have to stop at that floor. You are forbiden from using the staircase. No one else is in the elevator with you, so you don't have to stop if you don't want to. Calculate the minimum number of seconds required to get from floor 0 to floor k (passing floor k while inside an elevator that does not stop there does not count as "getting to floor k").

Input
The input will consist of a number of test cases. Each test case will begin with two numbers, n and k, on a line. The next line will contain the numbers T1T2,... Tn. Finally, the next n lines will contain sorted lists of integers - the first line will list the floors visited by elevator number 1, the next one will list the floors visited by elevator number 2, etc.

Output

For each test case, output one number on a line by itself - the minimum number of seconds required to get to floor k from floor 0. If it is impossible to do, print "IMPOSSIBLE" instead.

Sample InputSample Output
2 30
10 5
0 1 3 5 7 9 11 13 15 20 99
4 13 15 19 20 25 30
2 30
10 1
0 5 10 12 14 20 25 30
2 4 6 8 10 12 14 22 25 28 29
3 50
10 50 100
0 10 30 40
0 20 30
0 20 50
1 1
2
0 2 4 6 8 10
275
285
3920
IMPOSSIBLE

Explanation of examples

In the first example, take elevator 1 to floor 13 (130 seconds), wait 60 seconds to switch to elevator 2 and ride it to floor 30 (85 seconds) for a total of 275 seconds.

In the second example, take elevator 1 to floor 10, switch to elevator 2 and ride it until floor 25. There, switch back to elevator 1 and get off at the 30'th floor. The total time is 
10*10 + 60 + 15*1 + 60 + 5*10 = 285 seconds.

In example 3, take elevator 1 to floor 30, then elevator 2 to floor 20 and then elevator 3 to floor 50.

In the last example, the one elevator does not stop at floor 1.


题意:有一些电梯,每个电梯有指定的可以到的楼层和速度,中间换成一次电梯需要60秒,问到达第k层至少需要多少时间。

思路:用每个电梯把边给连起来,然后dis[i][j]=min(dis[i][j],dis[i][k]+dis[k][j]+60);

AC代码如下:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<cstdlib>
using namespace std;
int n,m,num[110],cost[10],dis[110][110],INF=1e9;
char c;
int main()
{
    int i,j,k,len,u,v,w;
    while(~scanf("%d%d",&n,&m))
    {
        for(i=1;i<=n;i++)
           scanf("%d",&cost[i]);
        for(i=0;i<=100;i++)
           for(j=0;j<=100;j++)
              dis[i][j]=INF;
        for(i=0;i<=100;i++)
           dis[i][i]=0;
        for(i=1;i<=n;i++)
        {
            num[0]=0;
            while(true)
            {
                scanf("%d",&k);
                num[++num[0]]=k;
                c=cin.peek();
                while(c==' ')
                {
                    cin.ignore();
                    c=cin.peek();
                }
                if(c=='\n')
                  break;
            }
            len=num[0];
            for(j=1;j<=len;j++)
               for(k=j+1;k<=len;k++)
               {
                   u=num[j];
                   v=num[k];
                   w=abs(u-v)*cost[i];
                   dis[u][v]=dis[v][u]=min(dis[u][v],w);
               }
        }
        for(k=0;k<100;k++)
           for(i=0;i<100;i++)
              for(j=0;j<100;j++)
                 dis[i][j]=min(dis[i][j],dis[i][k]+dis[k][j]+60);
        if(dis[0][m]>=INF)
          printf("IMPOSSIBLE\n");
        else
          printf("%d\n",dis[0][m]);
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值