Lining Up
``How am I ever going to solve this problem?" said the pilot.
Indeed, the pilot was not facing an easy task. She had to drop packages at specific points scattered in a dangerous area. Furthermore, the pilot could only fly over the area once in a straight line, and she had to fly over as many points as possible. All points were given by means of integer coordinates in a two-dimensional space. The pilot wanted to know the largest number of points from the given set that all lie on one line. Can you write a program that calculates this number?
Your program has to be efficient!
Input
The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.
The input consists of N pairs of integers, where 1 < N < 700. Each pair of integers is separated by one blank and ended by a new-line character. The list of pairs is ended with an end-of-file character. No pair will occur twice.
Output
For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.
The output consists of one integer representing the largest number of points that all lie on one line.
Sample Input
1 1 1 2 2 3 3 9 10 10 11
Sample Output
3
题意:问处在一条直线上的点最多有多少个。
思路:暴力可以,也可以枚举一个点,然后求其他点的斜率,找到相同斜率最多的数目。
AC代码如下:
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int T,t,n,maxn,f[1000010];
double num[1000010],eps=1e-8,x[1010],y[1010];
char c,s[1010];
int main()
{
int i,j,k,p,len;
scanf("%d",&T);
getchar();
cin.ignore();
for(t=1;t<=T;t++)
{
n=0;
while(gets(s))
{
len=strlen(s);
if(len==0)
break;
n++;
sscanf(s,"%lf%lf",&x[n],&y[n]);
}
maxn=1;
for(i=1;i<=n;i++)
{
p=0;
for(j=1;j<=n;j++)
if(i!=j)
num[++p]=(y[j]-y[i])/(x[j]-x[i]);
sort(num+1,num+1+p);
f[1]=1;
for(j=2;j<=p;j++)
{
if(num[j]-num[j-1]<eps)
f[j]=f[j-1]+1;
else
f[j]=1;
maxn=max(maxn,f[j]);
}
}
if(t!=1)
printf("\n");
printf("%d\n",maxn+1);
}
}