Square root - UVa 10023 大数开方

32 篇文章 0 订阅

Square root

The Problem

You are to determinate X by given Y, from expression 

The Input

The first line is the number of test cases, followed by a blank line.

Each test case of the input contains a positive integer Y (1<=Y<=101000), with no blanks or leading zeroes in it.
It is guaranteed, that for given Y, X will be always an integer.

Each test case will be separated by a single line.

The Output

For each test case, your program should print X in the same format as Y was given in input.

Print a blank line between the outputs for two consecutive test cases.

Sample Input

1

7206604678144

Sample Output

2684512


题意:大数开方。

思路:算作是一个模板收藏吧。

AC代码如下:

import java.math.BigInteger;
import java.util.Scanner;

public class Main
{
	public static void main(String[] args)
    {
		Scanner scan=new Scanner(System.in);
		BigInteger n,temp,y;
		BigInteger TWO=new BigInteger("2");
		int T,t,i,j,k;
		T=scan.nextInt();
		for(t=1;t<=T;t++)
		{
			n=scan.nextBigInteger();
			y=n;
			do {
                temp = y;  
                y = temp.add(n.divide(y)).divide(TWO);  
            }  
            while (y.compareTo(temp) == -1);  
			if(t!=1)
			  System.out.println();
			System.out.println(y);
		}
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值