Play the Dice - HDU 4586 期望dp

Play the Dice

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 1689    Accepted Submission(s): 548
Special Judge


Problem Description
There is a dice with n sides, which are numbered from 1,2,...,n and have the equal possibility to show up when one rolls a dice. Each side has an integer ai on it. Now here is a game that you can roll this dice once, if the i-th side is up, you will get ai yuan. What's more, some sids of this dice are colored with a special different color. If you turn this side up, you will get once more chance to roll the dice. When you roll the dice for the second time, you still have the opportunity to win money and rolling chance. Now you need to calculate the expectations of money that we get after playing the game once.
 

Input
Input consists of multiple cases. Each case includes two lines.
The first line is an integer n (2<=n<=200), following with n integers a i(0<=a i<200)
The second line is an integer m (0<=m<=n), following with m integers b i(1<=b i<=n), which are the numbers of the special sides to get another more chance.
 

Output
Just a real number which is the expectations of the money one can get, rounded to exact two digits. If you can get unlimited money, print inf.
 

Sample Input
  
  
6 1 2 3 4 5 6 0 4 0 0 0 0 1 3
 

Sample Output
  
  
3.50 0.00
 

题意:一个骰子有n个面,每个面有一个权值,掷到m个面时可以继续掷,问得到的权值的期望是多少。

思路:ans=不能继续掷:ai/n +  继续掷:(ai+ans)/n ,最后结果是ans=(a1+a2+...+an)/(n/m)。再特判inf的情况。

AC代码如下:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;
typedef long long ll;
int T,t,n,m,sum;
int main()
{
    int i,j,k;
    double ans;
    while(~scanf("%d",&n))
    {
        sum=0;
        for(i=1;i<=n;i++)
        {
            scanf("%d",&k);
            sum+=k;
        }
        scanf("%d",&m);
        for(j=1;j<=m;j++)
           scanf("%d",&k);
        if(sum==0)
           printf("0\n");
        else if(n==m)
          printf("inf\n");
        else
        {
            ans=round(100.0*sum/(n-m));
            printf("%.2f\n",ans/100);
        }
    }
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值