linux下PHP安装gd库

    在这里必须记录一下我gd的安装过程,首先说明一下,PHP我只是一个小白白,由于搭建个人博客的需要缩略图,所有需要PHP安装gd,PHP安装的时候默认是没有安装gd的,经过了周末两天的挣扎,终于把gd扩展按上了,超级开心,博客可以接着往下弄了。

    废话不多少,下面展示我安装的过程(历尽艰难啊~~~):

    由于gd依赖了一些扩展包,所以需要先安装依赖包,依赖包如下:

  • freetype-2.4.0.tar.bz2
  • jpegsrc.v9.tar.gz
  • zlib-1.2.8.tar.gz
  • libpng-1.6.16.tar.gz

    说明:PHP我使用的是5.6.31版本的,这些依赖包的版本是我亲测过的,安装的时候最好使用这些依赖包,zlib是libpng的依赖包,zlib和libpng的版本必须匹配上才能安装libpng成功,最新的zlib-1.2.11无法与libpng匹配,安装的时候要注意。

    依赖包下载地址:https://download.csdn.net/download/u014740338/10441203


1、安装freetype

tar jxvf freetype-2.4.0.tar.bz2
cd freetype-2.4.0
./configure --prefix=/usr/local/freetype
make && make install


2、安装jpegsrc

tar zxvf jpegsrc.v9.tar.gz
cd jpeg-9
./configure --prefix=/usr/local/jpeg && make && make install
mkdir -p /usr/local/jpeg/include \
mkdir -p /usr/local/jpeg/lib \
mkdir -p /usr/local/jpeg/bin \
mkdir -p /usr/local/jpeg/man/man1


3、安装zlib

tar -zxvf zlib-1.2.8.tar.gz
cd zlib-1.2.8
./configure --prefix=/usr/local/zlib

make && make install


4、安装安装libpng

tar -zxvf libpng-1.6.16.tar.gz
cd libpng-1.6.16
./configure --prefix=/usr/local/libpng

make && make install


5、进入PHP安装包里面的ext文件夹,找到gd扩展

cd /usr/local/php-5.6.31/ext/ (进入自己的PHP安装包)
/usr/local/php/bin/phpize (phpize在PHP的安装目录下,不知道可以通过find / -name phpize搜索)
./configure --with-php-config=/usr/local/php/bin/php-config --with-jpeg-dir=/usr/local/jpeg --with-png-dir=/usr/local/libpng --with-freetype-dir=/usr/local/freetype

如果出现configure: error: Problem with libpng.(a|so) or libz.(a|so). Please check config.log for more information
说明zlib和libpng版本不匹配,换个版本重新安装就好
make && make install
cp /usr/local/php/lib/php/extensions/no-debug-zts-20131226/gd.so /usr/local/php/extension/gd.so
vim /usr/local/php/etc/php.ini 添加:extension=gd.so

重启服务器,/usr/local/php/bin/php -m 就能看到了,看到下图说明安装成功!



参考资料:https://www.cnblogs.com/ttiandeng/p/6566027.html


©️2020 CSDN 皮肤主题: 编程工作室 设计师:CSDN官方博客 返回首页