acm pku 1080 Human Gene Functions的动态规划方法

Human Gene Functions

Description

It is well known that a human gene can be considered as a sequence, consisting of four nucleotides, which are simply denoted by four letters, A, C, G, and T. Biologists have been interested in identifying human genes and determining their functions, because these can be used to diagnose human diseases and to design new drugs for them.

A human gene can be identified through a series of time-consuming biological experiments, often with the help of computer programs. Once a sequence of a gene is obtained, the next job is to determine its function.
One of the methods for biologists to use in determining the function of a new gene sequence that they have just identified is to search a database with the new gene as a query. The database to be searched stores many gene sequences and their functions – many researchers have been submitting their genes and functions to the database and the database is freely accessible through the Internet.

A database search will return a list of gene sequences from the database that are similar to the query gene.
Biologists assume that sequence similarity often implies functional similarity. So, the function of the new gene might be one of the functions that the genes from the list have. To exactly determine which one is the right one another series of biological experiments will be needed.



Your job is to make a program that compares two genes and determines their similarity as explained below. Your program may be used as a part of the database search if you can provide an efficient one.
Given two genes AGTGATG and GTTAG, how similar are they? One of the methods to measure the similarity of two genes is called alignment. In an alignment, spaces are inserted, if necessary, in appropriate positions of the genes to make them equally long and score the resulting genes according to a scoring matrix.

For example, one space is inserted into AGTGATG to result in AGTGAT-G, and three spaces are inserted into GTTAG to result in –GT--TAG. A space is denoted by a minus sign (-). The two genes are now of equal length. These two strings are aligned:

AGTGAT-G
-GT--TAG

In this alignment, there are four matches, namely, G in the second position, T in the third, T in the sixth, and G in the eighth. Each pair of aligned characters is assigned a score according to the following scoring matrix.

 


denotes that a space-space match is not allowed. The score of the alignment above is (-3)+5+5+(-2)+(-3)+5+(-3)+5=9.

Of course, many other alignments are possible. One is shown below (a different number of spaces are inserted into different positions):

AGTGATG
-GTTA-G

This alignment gives a score of (-3)+5+5+(-2)+5+(-1) +5=14. So, this one is better than the previous one. As a matter of fact, this one is optimal since no other alignment can have a higher score. So, it is said that the
similarity of the two genes is 14.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case consists of two lines: each line contains an integer, the length of a gene, followed by a gene sequence. The length of each gene sequence is at least one and does not exceed 100.

Output

The output should print the similarity of each test case, one per line.

Sample Input

2 
7 AGTGATG 
5 GTTAG 
7 AGCTATT 
9 AGCTTTAAA 

Sample Output

14
21 

Source

Taejon 2001

       这是一道较为容易的动态规划问题,假设前后两个字符串cgene1cgene2的长度分别为igene1igene2,令ic[i][j]表示字符串cgene1的前i个字符和字符串cgene2的前j个字符的最大相似度,1iigen11jigen2, 则必定有如下关系:

ic[i][j] = max(ic[i-1][j-1]+iCost[igene1[i]][igene2[j]], ic[i][j-1]+iCost[4][igene2[j]],ic[i-1][j]+iCost[igene1[i][4]);

iCost是题目中给定的得分矩阵(scoring matrix)。根据上述公式,可以容易的求得需要的结果ic[igene1][igene2]

       在初始化的时候,有一点需要特别注意:因为这道题目,类似于一道求取两字符串最大公共子串的题目,在刚开始做这题目时,作者想当然地进行了如下初始化:

for(i = 1; i <= igene1; i ++) ic[i][0] = ;

for(i = 1; i <= igene2; i ++) ic[0][i] = ;

后来,仔细想想,这是完全错误的,因为当一某个字符串中没有字符与另一字符串中的字符对应时,其得分(代价)是不为零的。因此,需要进行如下初始化:

for(i = 1; i <= igene1; i ++) ic[i][0] = ic[i-1][0] + iCost[CharToInt(cgene1[i])][4];

for(i = 1; i <= igene2; i ++) ic[0][i] = ic[0][i-1] + iCost[4][CharToInt(cgene2[i])];

 

具体实现如下:

#include "iostream"

using namespace std;

 

int iCost[5][5] = {

       5,  -1, -2, -1, -3,

       -1,  5, -3, -2, -4,

       -2, -3,  5, -2, -2,

       -1, -2, -2,  5, -1,

       -3, -4, -2, -1, 0

};

 

int CharToInt(char ch)

{

       switch(ch)

       {

       case 'A': return 0;

       case 'C': return 1;

       case 'G': return 2;

       case 'T': return 3;

       default:  return 4;

       }

}

 

int Similarity(char *cgene1, int igene1, char *cgene2, int igene2)

{

       int ic[110][110];

       int i, j, max;

 

       ic[0][0] = 0;

       for(i = 1; i <= igene1; i ++) ic[i][0] = ic[i-1][0] + iCost[CharToInt(cgene1[i])][4];

       for(i = 1; i <= igene2; i ++) ic[0][i] = ic[0][i-1] + iCost[4][CharToInt(cgene2[i])];

 

       for(i = 1; i <= igene1; i ++)

       {

              for(j = 1; j <= igene2; j ++)

              {

                     max = ic[i-1][j-1] + iCost[CharToInt(cgene1[i])][CharToInt(cgene2[j])];

                     if(max < ic[i-1][j] + iCost[CharToInt(cgene1[i])][4])

                     {

                            max = ic[i-1][j] + iCost[CharToInt(cgene1[i])][4];

                     }

                     if(max < ic[i][j-1] + iCost[4][CharToInt(cgene2[j])])

                     {

                            max = ic[i][j-1] + iCost[4][CharToInt(cgene2[j])];

                     }

                     ic[i][j] = max;

              }

       }

       return ic[igene1][igene2];

}

 

int main(void)

{

       int T, igene1, igene2;

       char cgene1[105], cgene2[105];

       cin >> T;

       while(T--)

       {

              int i;

 

              cin >> igene1;

              for(i = 1; i <= igene1; i++)

              {

                     cin >> cgene1[i];

              }

              cgene1[igene1+1] = '/0';

              cin >> igene2;

              for(i = 1; i <= igene2; i++)

              {

                     cin >> cgene2[i];

              }

              cgene2[igene2+1] = '/0';

 

              cout << Similarity(cgene1, igene1, cgene2, igene2) << endl;;

       }

 

       return 0;

}

 

执行结果:

Problem: 1080

 

User: uestcshe

Memory: 252K

 

Time: 0MS

Language: C++

 

Result: Accepted

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值