acm pku 1144 ID Codes的算法分析

ID Codes

Description

It is 2084 and the year of Big Brother has finally arrived, albeit a century late. In order to exercise greater control over its citizens and thereby to counter a chronic breakdown in law and order, the Government decides on a radical measure--all citizens are to have a tiny microcomputer surgically implanted in their left wrists. This computer will contains all sorts of personal information as well as a transmitter which will allow people's movements to be logged and monitored by a central computer. (A desirable side effect of this process is that it will shorten the dole queue for plastic surgeons.)

An essential component of each computer will be a unique identification code, consisting of up to 50 characters drawn from the 26 lower case letters. The set of characters for any given code is chosen somewhat haphazardly. The complicated way in which the code is imprinted into the chip makes it much easier for the manufacturer to produce codes which are rearrangements of other codes than to produce new codes with a different selection of letters. Thus, once a set of letters has been chosen all possible codes derivable from it are used before changing the set.

For example, suppose it is decided that a code will contain exactly 3 occurrences of `a', 2 of `b' and 1 of `c', then three of the allowable 60 codes under these conditions are:

      abaabc

      abaacb

      ababac
 


These three codes are listed from top to bottom in alphabetic order. Among all codes generated with this set of characters, these codes appear consecutively in this order.

Write a program to assist in the issuing of these identification codes. Your program will accept a sequence of no more than 50 lower case letters (which may contain repeated characters) and print the successor code if one exists or the message `No Successor' if the given code is the last in the sequence for that set of characters.

Input

Input will consist of a series of lines each containing a string representing a code. The entire file will be terminated by a line consisting of a single #.

Output

Output will consist of one line for each code read containing the successor code or the words 'No Successor'.

Sample Input

abaacb
cbbaa
#

Sample Output

ababac
No Successor

Source

New Zealand 1991 Division I,UVA 146

 

       分析:对某个包含某些特定数字(0~9)的数,求包含这些数字且比已知数大的最小数。这道题目只不过是把具体的数字(0~9)换成了小写字母(a~z),其具体算法如下:

1,  从字符串末尾开始,对某个字符str[i],找出它前面离它最近的,且比它小的字符str[j](显然j<i)。若不存在这样的字符,则i--,继续寻找满足条件的j, i== 0,则输出”No Successor” 否则:

2,  交换str[i]str[j];对str[i+1]以及其后的字母按从小到大的次序进行排列,并将排列的结果接到str[i]之后,则新的str就是所有的结果。

 

具体实现:

#include "iostream"

#include "string.h"

#include "stdlib.h"

 

using namespace std;

//Compiler error1

const int N = 55;

char str[N];

 

int cmp(const void *a, const void *b)

{

       return *(char *)a - *(char *)b;

}

 

void Successor(char *str)

{

       int i, j, len = strlen(str);

       bool flag = false;

       char chr, *ctmp;

       ctmp = new char[N];

       ctmp[0] = '/0';

 

       for(i = len-1; i > 0; i--)

       {

              for(j = i-1; j > -1; j--)

              {

                     if(str[i] > str[j])

                     {

                            chr = str[i];

                            str[i] = str[j];

                            str[j] = chr;

                            flag = true;

                            break;

                     }

              }

              if(flag) break;

       }

       if(i == 0) cout << "No Successor" <<endl;

       else

       {

              strcpy(ctmp, &str[j+1]);

              str[j+1] = '/0';

              qsort(ctmp, strlen(ctmp), sizeof(char), cmp);

              strcat(str, ctmp);

              cout << str <<endl;

       }

}

 

int main(void)

{

       cin >> str;

       while(strcmp(str, "#") != 0)

       {

              Successor(str);

              cin >> str;

       }

       return 0;

}

 

执行结果:

 

Problem: 1146

 

User: uestcshe

Memory: 680K

 

Time: 0MS

Language: G++

 

Result: Accepted

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值