[最小树形图(朱刘算法)] F - Teen Girl Squad UVA - 11183

You are part of a group of n teenage girls armed with cellphones. You have some news you want
to tell everyone in the group. The problem is that no two of you are in the same room, and you must
communicate using only cellphones. What’s worse is that due to excessive usage, your parents have
refused to pay your cellphone bills, so you must distribute the news by calling each other in the cheapest
possible way. You will call several of your friends, they will call some of their friends, and so on until
everyone in the group hears the news.
Each of you is using a different phone service provider, and you know the price of girl A calling girl B for all possible A and B. Not all of your friends like each other, and some of them will never
call people they don’t like. Your job is to find the cheapest possible sequence of calls so that the news

spreads from you to all n-1 other members of the group.


Input
The first line of input gives the number of cases, N (N < 150). N test cases follow. Each one starts
with two lines containing n (0 ≤ n ≤ 1000) and m (0 ≤ m ≤ 40, 000). Girls are numbered from 0 to
n-1, and you are girl 0. The next m lines will each contain 3 integers, u, v and w, meaning that a call
from girl u to girl v costs w cents (0 ≤ w ≤ 1000). No other calls are possible because of grudges,

rivalries and because they are, like, lame. The input file size is around 1200 KB.


Output
For each test case, output one line containing ‘Case #x:’ followed by the cost of the cheapest method

of distributing the news. If there is no solution, print ‘Possums!’ instead.


Sample Input
4
2
1
0 1 10
2
1
1 0 10
4
4
0 1 10
0 2 10
1 3 20
2 3 30
4
4
0 1 10
1 2 20
2 0 30
2 3 100
Sample Output
Case #1: 10
Case #2: Possums!
Case #3: 40
Case #4: 130



#include <bits/stdc++.h>
using namespace std;

const int inf = 0x3f3f3f3f;
const int mn = 1010, mm = 40010;

int n, m;
int s[mn][mn];
bool flag[mn];
bool vis[mn];
int pre[mn];

int zhuliu(int r)
{
	int ans = 0;
	memset(flag, 0, sizeof flag);
	
	while(1)
	{
		for (int i = 0; i < n; i++)
		{
			if (i == r || flag[i])
				continue;
	
			pre[i] = i;
			s[i][i] = inf;
			for (int j = 0; j < n; j++)
				if (!flag[j] && s[j][i] < s[pre[i]][i])
				pre[i] = j;
				
			if (pre[i] == i)
				return -1;
		}
		
		int i;
		for (i = 0; i < n; i++)
		{
			if (i == r || flag[i])
				continue;
			
			int j = i, cnt = 0;
			while(j != r && pre[j] != i &&cnt <= n)
				j = pre[j], cnt ++;
			if (j == r || cnt > n)
				continue;
			break;
		}
		
		if (i == n)
		{
			for (int j = 0; j < n; j++)
				if (j != r && !flag[j])
					ans += s[pre[j]][j];
			return ans;
		}
		
		memset(vis, 0, sizeof vis);
		int j = i;
		do
		{
			ans += s[pre[j]][j];
			j = pre[j];
			vis[j] = 1;
			flag[j] = 1;
		} while(j != i);
		flag[i] = 0;
		
		for (j = 0; j < n; j++)
		{
			if (!vis[j])
				continue;
			for (int k = 0; k < n; k++)
			{
				if (vis[k])
					continue;
				if (s[i][k] > s[j][k])
					s[i][k] = s[j][k];
				if (s[k][j] < inf && (s[k][j] - s[pre[j]][j]) < s[k][i])
					s[k][i] = s[k][j] - s[pre[j]][j];
			}
		}
	}
}
int main()
{
	int T;
	scanf("%d", &T);
	for (int u = 1; u <= T; u++)
	{
		scanf("%d %d", &n, &m);
		for (int i = 0; i < n; i++)
			for (int j = 0; j < n; j++)
			s[i][j] = inf;
		for (int i = 0; i < m; i++)
		{
			int a, b, c;
			scanf("%d %d %d", &a, &b, &c);
			s[a][b] = c;
		}
		
		int ans = zhuliu(0);
		
		printf("Case #%d: ", u);
		if (ans == -1)
			printf("Possums!\n");
		else
			printf("%d\n", ans);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值