【Trie树】是否存在一个字符串是另一个字符串的前缀 HDU - 1671

Phone List

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 25827    Accepted Submission(s): 8637


 

Problem Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.

 

 

Input

The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

 

 

Output

For each test case, output “YES” if the list is consistent, or “NO” otherwise.

 

 

Sample Input

 

2

3

911

97625999

91125426

5

113

12340

123440

12345

98346

 

 

Sample Output

 

NO

YES

 

 

Source

2008 “Insigma International Cup” Zhejiang Collegiate Programming Contest - Warm Up(3)

 

 

#include <bits/stdc++.h>
using namespace std;

const int mn = 10010, ml = 15;

char s[mn][ml];

int num;
int trie[mn * ml][10];
int ed[mn * ml];
void add(char ch[], int pos)
{
	int rt = 0;
	for (int i = 0, len = strlen(ch); i < len; i++)
	{
		int id = ch[i] - '0';
		if (trie[rt][id] == 0)
			trie[rt][id] = ++num;
		rt = trie[rt][id];
	}
	ed[rt] = pos;  // 此处结束的是第几个字符串
}
bool ask(char ch[], int pos)
{
	int rt = 0;
	for (int i = 0, len = strlen(ch); i < len; i++)
	{
		rt = trie[rt][ch[i] - '0'];
		if (ed[rt] && ed[rt] != pos) // 有字符串在此结束且不是自身
			return 0;
	}
	return 1;
}
int main()
{
	#ifndef ONLINE_JUDGE
		freopen("D:\\in.txt", "r", stdin);
	#endif // ONLINE_JUDGE
	
	int T;
	scanf("%d", &T);
	while (T--)
	{
		num = 0;
		memset(ed, 0, sizeof ed);
		memset(trie, 0, sizeof trie);
		
		int n;
		scanf("%d", &n);
		for (int i = 1; i <= n; i++)
		{
			scanf("%s", s[i]);
			add(s[i], i);
		}
		bool flag = 1;
		for (int i = 1; i <= n; i++)
		{
			flag = ask(s[i], i);
			if (!flag)
				break;
		}
		
		if (flag)
			cout << "YES" << endl;
		else 
			cout << "NO" << endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值