【trie树】查找由其他两个字符串组成的串 HDU1247

Hat’s Words

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19117    Accepted Submission(s): 6750


 

Problem Description

A hat’s word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.
You are to find all the hat’s words in a dictionary.

 

 

Input

Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 50,000 words.
Only one case.

 

 

Output

Your output should contain all the hat’s words, one per line, in alphabetical order.

 

 

Sample Input

 

a

ahat

hat

hatword

hziee

word

 

 

Sample Output

 

ahat

hatword

 

#include <bits/stdc++.h>
using namespace std;
const int mn = 50010, mm = 85;

char ch[mn][mm];
bool ed[mn * mm];
int trie[mn * mm][30];

int num;
void add(char ch[])
{
	int len = strlen(ch);
	int r = 0;
	for (int i = 0; i < len; i++)
	{
		int t = ch[i] - 'a';
		if (trie[r][t] == 0)
			trie[r][t] = ++num;
		r = trie[r][t];
	}
	ed[r] = 1;
}
bool ask(char ch[])
{
	int r = 0;
	int len = strlen(ch);
	for (int i = 0; i < len; i++)
	{
		int t = ch[i] - 'a';
		if (trie[r][t] == 0)
			return 0;
		r = trie[r][t];
	}
	if (ed[r] == 1)
		return 1;
	else
		return 0;
}

int main()
{
	int cas = 1;
	while (~scanf("%s", ch[cas]))
	{
		add(ch[cas]);
		cas++;
	}

	char s1[mm], s2[mm];
	for (int i = 1; i < cas; i++)
	{
		int len = strlen(ch[i]);
		for (int j = 1; j < len - 1; j++) // 枚举断点
		{
			strncpy(s1, ch[i], j);
			s1[j] = '\0';
			if (ask(s1) == 0)
				continue;

			strncpy(s2, ch[i] + j, len - j);
			s2[len - j] = '\0';
			if (ask(s2) == 1)
			{
				printf("%s\n", ch[i]);
				break;
			}
		}
	} // O(n * m * m)
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值