【01Trie树】 加入删除字符串 HDU5536

Chip Factory

Time Limit: 18000/9000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 5067    Accepted Submission(s): 2280


 

Problem Description

John is a manager of a CPU chip factory, the factory produces lots of chips everyday. To manage large amounts of products, every processor has a serial number. More specifically, the factory produces n chips today, the i-th chip produced this day has a serial number si.

At the end of the day, he packages all the chips produced this day, and send it to wholesalers. More specially, he writes a checksum number on the package, this checksum is defined as below:

maxi,j,k(si+sj)⊕sk


which i,j,k are three different integers between 1 and n. And ⊕ is symbol of bitwise XOR.

Can you help John calculate the checksum number of today?

 

 

Input

The first line of input contains an integer T indicating the total number of test cases.

The first line of each test case is an integer n, indicating the number of chips produced today. The next line has n integers s1,s2,..,sn, separated with single space, indicating serial number of each chip.

1≤T≤1000
3≤n≤1000
0≤si≤109
There are at most 10 testcases with n>100

 

 

Output

For each test case, please output an integer indicating the checksum number in a line.

 

 

Sample Input

 

2

3

1 2 3

3

100 200 300

 

 

Sample Output

 

6

400

 

 

Source

2015ACM/ICPC亚洲区长春站-重现赛(感谢东北师大)

 

 

#include <bits/stdc++.h>
using namespace std;

const int mt = 1005, mn = 1010, ms = 1e9 + 10;

int s[mn];

int num;
int trie[mn * 35][2], val[mn * 35], cnt[mn * 35];
void add(int a)
{
	int r = 0;
	for (int i = 31; i >= 0; i--)
	{
		int t = ((1 << i) & a) ? 1 : 0;  /// 01字典树子节点
		if (!trie[r][t])
			trie[r][t] = ++num;
		r = trie[r][t];
		cnt[r]++; /// 经过r的次数
	}
	val[r] = a;
}
void des(int a) /// 删除字符串
{
	int r = 0;
	for (int i = 31; i >= 0; i--)
	{
		int t = ((1 << i) & a) ? 1 : 0;
		r = trie[r][t];
		cnt[r]--; /// 经过r次数 -1
	}
}
int ask(int a)
{
	int r = 0;
	for (int i = 31; i >= 0; i--)
	{
		int t = ((1 << i) & a) ? 1 : 0;
		if (trie[r][t ^ 1] && cnt[trie[r][t ^ 1]]) /// 有子节点且子节点有经过的字符串
			r = trie[r][t ^ 1];
		else
			r = trie[r][t];
	}
	return a ^ val[r];
}

int main()
{
	int T;
	scanf("%d", &T);
	while (T--)
	{
		num = 0;
		memset(cnt, 0, sizeof cnt);
		memset(val, 0, sizeof val);
		memset(trie, 0, sizeof trie);

		int n;
		scanf("%d", &n);
		for (int i = 1; i <= n; i++)
		{
			scanf("%d", &s[i]);
			add(s[i]);
		}
		int ans = 0;
		for (int i = 1; i <= n; i++) // 枚举
		{
			des(s[i]); /// 删除枚举到的字符串
			for (int j = i + 1; j <= n; j++)
			{
				des(s[j]);
				ans = max(ans, ask(s[i] + s[j])); /// 计算当前最大异或值
				add(s[j]); /// 将删除的字符串重新加入
			}
			add(s[i]);
		}
		printf("%d\n", ans);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值