[优化dfs] 小数据求固定大小的团数量 HDUCounting Cliques

A clique is a complete graph, in which there is an edge between every pair of the vertices. Given a graph with N vertices and M edges, your task is to count the number of cliques with a specific size S in the graph. 

Input

The first line is the number of test cases. For each test case, the first line contains 3 integers N,M and S (N ≤ 100,M ≤ 1000,2 ≤ S ≤ 10), each of the following M lines contains 2 integers u and v (1 ≤ u < v ≤ N), which means there is an edge between vertices u and v. It is guaranteed that the maximum degree of the vertices is no larger than 20.

Output

For each test case, output the number of cliques with size S in the graph.

Sample Input

3
4 3 2
1 2
2 3
3 4
5 9 3
1 3
1 4
1 5
2 3
2 4
2 5
3 4
3 5
4 5
6 15 4
1 2
1 3
1 4
1 5
1 6
2 3
2 4
2 5
2 6
3 4
3 5
3 6
4 5
4 6
5 6

Sample Output

3
7
15

 

 

#include <bits/stdc++.h>
using namespace std;

const int mn = 105, mm = 1010;

int ans;

int ne;
bool mp[mn][mn];
int to[mm], nx[mm], fr[mn];
void addedge(int s, int t)
{
	if (s > t)
		swap(s, t);
	mp[s][t] = 1; /// 建单向边, 从编号小到大
	
	to[ne] = t;
	nx[ne] = fr[s];
	fr[s] = ne++;
}

int n, m, S;
int cl[25];
void dfs(int s, int id)
{
	cl[s] = id;
	if (s == S) // 达到数量
	{
		ans++;
		return;
	}
	for (int i = fr[id]; i != -1; i = nx[i]) // 枚举id可到达的点
	{
		int t = to[i];
		bool flag = 1;
		for (int j = 1; j < s; j++) // 已经在团内的点
			if (!mp[cl[j]][t]) // 有不连通 不可加入
			flag = 0;
		if (flag)
			dfs(s + 1, t);
	}
}

int main()
{
	int T;
	scanf("%d", &T);
	while (T--)
	{
		ne = 0;
		memset(fr, -1, sizeof fr);
		memset(mp, 0, sizeof mp);
		
		scanf("%d %d %d", &n, &m, &S);
		while (m--)
		{
			int a, b;
			scanf("%d %d", &a, &b);
			addedge(a, b);
		}
		
		ans = 0;
		for (int i = 1; i <= n; i++)
			dfs(1, i);
		
		printf("%d\n", ans);
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值