[后缀数组] 求不同子串总数 SPOJ - DISUBSTR

32 篇文章 0 订阅
3 篇文章 0 订阅

DISUBSTR - Distinct Substrings

#suffix-array-8

 

Given a string, we need to find the total number of its distinct substrings.

Input

T- number of test cases. T<=20;
Each test case consists of one string, whose length is <= 1000

Output

For each test case output one number saying the number of distinct substrings.

Example

Sample Input:
2
CCCCC
ABABA

Sample Output:
5
9

Explanation for the testcase with string ABABA: 
len=1 : A,B
len=2 : AB,BA
len=3 : ABA,BAB
len=4 : ABAB,BABA
len=5 : ABABA
Thus, total number of distinct substrings is 9.

 

 

子串是后缀的前缀
ans = 所有子串 - 相同前缀数量(height之和)

#include <bits/stdc++.h>
using namespace std;
const int mn = 1010;

int c[mn], x[mn], y[mn];
int sa[mn], Rank[mn], height[mn];
bool cmp(int *r, int a, int b, int l)
{
	return r[a] == r[b] && r[a + l] == r[b + l];
}
void da(char str[], int n, int m)
{
	n++;
	for (int i = 0; i < m; i++)
		c[i] = 0;
	for (int i = 0; i < n; i++)
		c[x[i] = str[i]]++;
	for (int i = 1; i < m; i++)
		c[i] += c[i - 1];
	for (int i = n - 1; i >= 0; i--)
		sa[--c[x[i]]] = i;
		
	for (int j = 1; j <= n; j <<= 1)
	{
		int p = 0;
		for (int i = n - j; i < n; i++)
			y[p++] = i;
		for (int i = 0; i < n; i++)
			if (sa[i] >= j)
			y[p++] = sa[i] - j;
		
		for (int i = 0; i < m; i++)
			c[i] = 0;
		for (int i = 0; i < n; i++)
			c[x[y[i]]]++;
		for (int i = 1; i < m; i++)
			c[i] += c[i - 1];
		for (int i = n - 1; i >= 0; i--)
			sa[--c[x[y[i]]]] = y[i];
			
		swap(x, y);
		p = 1;
		x[sa[0]] = 0;
		for (int i = 1; i < n; i++)
			x[sa[i]] = cmp(y, sa[i - 1], sa[i], j) ? p - 1 : p++;
		if (p >= n)
			break;
		m = p;
	}
	int k = 0;
	n--;
	for (int i = 0; i <= n; i++)
		Rank[sa[i]] = i;
	for (int i = 0; i < n; i++)
	{
		if (k)
			k--;
		int j = sa[Rank[i] - 1];
		while (str[i + k] == str[j + k])
			k++;
		height[Rank[i]] = k;
	}
}

char ch[mn];
int main()
{
	int T;
	scanf("%d", &T);
	while (T--)
	{
		scanf("%s", ch);
		int len = strlen(ch);
		da(ch, len, 128);
		
		int sum = (len + 1) * len / 2;
		int tans = 0;
		for (int i = 1; i <= len; i++)
			tans += height[i];
		printf("%d\n", sum - tans);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值