区间动态规划 矩阵连乘 Medium 经典dp练习题

3 篇文章 0 订阅

Time limit: 1000 ms
Memory limit: 65536 kB
OS: Linux
Source: Northeastern Europe 2001, Far-Eastern Subregion

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row.

The goal is to take cards in such order as to minimize the total number of scored points.

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring
10150 + 50205 + 10505 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be
15020 + 1205 + 1015 = 1000+100+50 = 1150.

Input
The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

Output
Output must contain a single integer - the minimal score.

Sample Input

6
10 1 50 50 20 5

Sample Output

3650

vj题源

题意:每一次取字符串中的一个数字(除了头尾),每取出一个数字便与两边的数相乘,最后将其总和求出来,要求最小的和。

解题思路:可以将其视为多个子序列进行计算,运用dp降低计算的过程。

#include<bits/stdc++.h>
using namespace std;
const int INF = 0x3f3f3f3f;
int a[105], dp[105][105];
void Work(int n)
{
    memset(dp, 0, sizeof(dp));
    for(int len = 2; len < n; len++)
    {
        for(int i = 1; i <= n-1; i++)
        {
            int  j = i + len;//先是间隔为一,然后到头与尾。
            dp[i][j] = INF;
            for(int k = i + 1; k < j; k++)
                dp[i][j] = min(dp[i][j], dp[i][k] + dp[k][j] + a[i]*a[k]*a[j]);
        }
    }
    printf("%d\n", dp[1][n]);
}
int main()
{
    int n;
    scanf("%d", &n);
    for(int i = 1; i <= n; i++) scanf("%d", &a[i]);
    Work(n);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值