并查集中的最小生成树

55 篇文章 0 订阅
9 篇文章 0 订阅

最小生成树————结构体 + 并查集
给一个例题:Constructing Roads
Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input
3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output
179

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
int tp[10000];
***struct xx
{
    int a, b, dis;
}x[10001];
int cmp(const void *x, const void *y)
{
    struct xx x1 = *(struct xx *)x;
    struct xx y1 = *(struct xx *)y;
    return (x1.dis - y1.dis);
}
void init()
{
    for(int i = 1; i < 10000; i ++)
        tp[i] = i;
}
int find(int x)
{
    int t = x;
    while(t != tp[t])
        t = tp[t];
    while(x != tp[x])
    {
        int tmp = tp[x];
        tp[x] = t;
        x = tmp;
    }
    return t;
}
void merge(int x, int y)
{
    x = find(x);
    y = find(y);
    if(x != y)
        tp[y] = x;
}***
int main()
{
    int n, m, x0, y0;
    while(~scanf("%d", &n))
    {
        init();
        int k = 0;
        for(int i = 0; i < n; i++)
        {
            for(int j = 0; j < n; j++)
            {
                scanf("%d", &x[k].dis);
                x[k].a = i + 1;
                x[k].b = j + 1;
                k++;
            }
        }
        qsort(x, k, sizeof(x[0]), cmp);
        scanf("%d", &m);
        for(int i = 0; i < m; i++)
        {
            scanf("%d %d", &x0, &y0);
            merge(x0, y0);
        }
        int sum = 0;
        ***for(int i = 0; i < k; i++)
        {
            if(find(x[i].a) != find(x[i].b))
            {
                merge(x[i].a, x[i].b);
                sum += x[i].dis;
            }
        }***
        printf("%d\n", sum);
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Kruskal算法是一种用于求解最小生成树的算法,它的基本思想是将所有边按照权值从小到大排序,然后依次加入到生成树,如果加入一条边会形成环,则不加入该边。最终得到的生成树就是最小生成树。 在MATLAB实现Kruskal算法,可以先将所有边按照权值从小到大排序,然后依次加入到生成树,使用并查集来判断是否形成环。具体实现可以参考以下步骤: 1. 将所有边按照权值从小到大排序。 2. 初始化并查集,将每个节点都单独成为一个集合。 3. 依次加入边,如果加入一条边会形成环,则不加入该边。 4. 最终得到的生成树就是最小生成树。 具体实现可以参考以下MATLAB代码: function [MST, cost] = kruskal(G) % G为邻接矩阵,表示图的边权 n = size(G, 1); E = []; for i = 1:n for j = i+1:n if G(i,j) > E = [E; i, j, G(i,j)]; end end end E = sortrows(E, 3); % 按照边权从小到大排序 parent = 1:n; rank = zeros(1, n); MST = []; cost = ; for i = 1:size(E,1) u = E(i,1); v = E(i,2); w = E(i,3); pu = find(parent, u); pv = find(parent, v); if pu ~= pv % 如果不在同一个集合,则加入该边 MST = [MST; u, v]; cost = cost + w; if rank(pu) < rank(pv) parent(pu) = pv; elseif rank(pu) > rank(pv) parent(pv) = pu; else parent(pv) = pu; rank(pu) = rank(pu) + 1; end end end end 其,find(parent, u)和find(parent, v)是并查集的查找操作,用于查找节点u和节点v所在的集合。如果它们在同一个集合,则说明加入该边会形成环,不加入该边;否则,将它们所在的集合合并成一个集合,并将该边加入到生成树。rank数组用于记录每个集合的深度,用于优化并查集的合并操作。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值