静态存储普通树bfs+dfs。注意:输入叶结点,tree[num].child.push_back(x)而不是tree[i]…A1004 Counting Leaves (30分)

1004 Counting Leaves (30分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

AC代码(自己写的)dfs版本:

#include <iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<string.h>
using namespace std;
#pragma warning(disable:4996)
#include<string>
#include<stack>
#include<map>
#include<queue>
#include<set>
//A1004 16:15
const int maxn = 100 + 10;
const int INF = 0x7fffffff;
int n, m, num_leaf[maxn] = { 0 }, max_step=0;//root's id=01
struct node {
	int step;
	vector<int> child;
}tree[maxn];

void dfs(int index, int step) {
	int numchild = tree[index].child.size();
	tree[index].step = step;
	if (numchild == 0) {//leaf node
		num_leaf[step]++;
		//printf("leaf:%d, step:%d, num_leaf:%d\n", index, step, num_leaf[step]);
		if (step > max_step)
			max_step = step;
	}
	else {
		for (int i = 0; i < numchild; i++) {
			dfs(tree[index].child[i], step + 1);
		}
	}
}

int main() {
	scanf("%d %d", &n, &m);
	for (int i = 0; i < m; i++) {
		int num, k, x;
		scanf("%d %d", &num, &k);
		for (int j = 0; j < k; j++) {
			scanf("%d", &x);
			tree[num].child.push_back(x);
		}
	}
	dfs(1, 1);
	//printf("max_step:%d\n", max_step);
	for (int i = 1; i <= max_step; i++) {
		printf("%d%c", num_leaf[i], i == max_step ? '\n' : ' ');
	}
	return 0;
}

 

AC代码bfs版本(算法笔记):

#include <iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<string.h>
using namespace std;
#pragma warning(disable:4996)
#include<string>
#include<stack>
#include<map>
#include<queue>
#include<set>
//A1004 16:15
const int maxn = 100 + 10;
const int INF = 0x7fffffff;
vector<int> tree[maxn];
int step[maxn] = { 0 }, leaf[maxn] = { 0 };
int max_step = 0;

void bfs() {
	queue<int> q;
	q.push(1);
	while (!q.empty()) {
		int temp = q.front();
		q.pop();
		if (step[temp] > max_step)
			max_step = step[temp];
		if (tree[temp].size() == 0)
			leaf[step[temp]]++;
		for (int i = 0; i < tree[temp].size(); i++) {
			step[tree[temp][i]] = step[temp] + 1;
			q.push(tree[temp][i]);
		}
	}
}

int main() {
	int n, m;
	scanf("%d %d", &n, &m);
	for (int i = 0; i < m; i++) {
		int num, k, x;
		scanf("%d %d", &num, &k);
		for (int j = 0; j < k; j++) {
			scanf("%d", &x);
			tree[num].push_back(x);
		}
	}
	step[1] = 1;
	bfs();
	for (int i = 1; i <= max_step; i++)
		printf("%d%c", leaf[i], i == max_step ? '\n' : ' ');
	return 0;
}
/*
23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18
*/

 

评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值