【不太容易想】给出二叉树前序和中序,不建树的情况下求后序的第一个结点--1138 Postorder Traversal (25 分)

1138 Postorder Traversal (25 分)

Suppose that all the keys in a binary tree are distinct positive integers. Given the preorder and inorder traversal sequences, you are supposed to output the first number of the postorder traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the first number of the postorder traversal sequence of the corresponding binary tree.

Sample Input:

7
1 2 3 4 5 6 7
2 3 1 5 4 7 6

Sample Output:

3

AC代码:

#include<cstdio>
#include<stdlib.h>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstring>
#pragma warning(disable:4996)
using namespace std;
#include<string>
#include<vector>
#include<map>
#include<set>
#include<stack>
const int maxn = 100000 + 10;
const int INF = 0x7fffffff;
vector<int> pre, in;
int flag = 0;
void postOrder(int inl, int inr, int prel, int prer) {
	if (inl > inr)return;
	int root = prel;
	int k;
	for (k = inl; k <= inr; k++)
		if (in[k] == pre[prel])
			break;
	postOrder(inl, k - 1, prel + 1, prel + (k - inl));
	postOrder(k + 1, inr, prel + (k - inl + 1), prer);
	if (flag == 0) {
		flag = 1;
		printf("%d\n", in[k]);
		return;
	}
}
int main() {
	int n;
	scanf("%d", &n);
	pre.resize(n);
	in.resize(n);
	for (int i = 0; i < n; i++)
		scanf("%d", &pre[i]);
	for (int i = 0; i < n; i++)
		scanf("%d", &in[i]);
	postOrder(0, n - 1, 0, n - 1);
	return 0;
}

后序是先遍历左子树,再遍历右子树,然后访问根节点。只要有输出,就停止。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值