dp---1088:滑雪

总时间限制:

1000ms

内存限制:

65536kB

描述

Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个区域中最长的滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子

 1  2  3  4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9


一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-...-3-2-1更长。事实上,这是最长的一条。

输入

输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。

输出

输出最长区域的长度。

样例输入

5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

样例输出

25

AC代码:

#include<cstdio>
#include<stdlib.h>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstring>
#pragma warning(disable:4996)
using namespace std;
#include<string>
#include<vector>
#include<map>
#include<set>
#include<stack>
#include<queue>
#include<unordered_map>
#include<unordered_set>
const int maxn = 10000 + 10;
const int INF = 0x3f3f3f3f;//若相加且为7ffffff时会越界,然后WA!!
struct info {
	int r, c;
	int h;
	bool operator < (const info &x) const {
		return h < x.h;
	}
}points[maxn];
int field[110][110], ans[110][110];
int r, c;
int main(){
	fill(ans[0], ans[0] + 110 * 110, 1);
	scanf("%d%d", &r, &c);
	for (int i = 0; i < r; i++)
		for (int j = 0; j < c; j++) {
			scanf("%d", &field[i][j]);
			points[i*c + j].h = field[i][j];
			points[i*c + j].r = i;
			points[i*c + j].c = j;
		}
	sort(points, points + r * c);
	for (int i = 1; i < r*c; i++) {
		int tmp_r = points[i].r;
		int tmp_c = points[i].c;
		if (tmp_r > 0 && field[tmp_r - 1][tmp_c] < field[tmp_r][tmp_c])
			ans[tmp_r][tmp_c] = max(ans[tmp_r][tmp_c], ans[tmp_r - 1][tmp_c] + 1);
		if (tmp_r < r-1 && field[tmp_r + 1][tmp_c] < field[tmp_r][tmp_c])
			ans[tmp_r][tmp_c] = max(ans[tmp_r][tmp_c], ans[tmp_r + 1][tmp_c] + 1);
		if (tmp_c > 0 && field[tmp_r][tmp_c - 1] < field[tmp_r][tmp_c])
			ans[tmp_r][tmp_c] = max(ans[tmp_r][tmp_c], ans[tmp_r][tmp_c - 1] + 1);
		if (tmp_c < c - 1 && field[tmp_r][tmp_c + 1] < field[tmp_r][tmp_c])
			ans[tmp_r][tmp_c] = max(ans[tmp_r][tmp_c], ans[tmp_r][tmp_c + 1] + 1);
	}
	int max_len = 0;
	for (int i = 0; i < r; i++)
		for (int j = 0; j < c; j++)
			max_len = max(max_len, ans[i][j]);
	printf("%d\n", max_len);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值