Stall Reservations
Time Limit: 1000MS | Memory Limit: 65536K | |||
Total Submissions: 18736 | Accepted: 6502 | Special Judge |
Description
Oh those picky N (1 <= N <= 50,000) cows! They are so picky that each one will only be milked over some precise time interval A..B (1 <= A <= B <= 1,000,000), which includes both times A and B. Obviously, FJ must create a reservation system to determine which stall each cow can be assigned for her milking time. Of course, no cow will share such a private moment with other cows.
Help FJ by determining:
- The minimum number of stalls required in the barn so that each cow can have her private milking period
- An assignment of cows to these stalls over time
Many answers are correct for each test dataset; a program will grade your answer.
Input
Line 1: A single integer, N
Lines 2..N+1: Line i+1 describes cow i's milking interval with two space-separated integers.
Output
Line 1: The minimum number of stalls the barn must have.
Lines 2..N+1: Line i+1 describes the stall to which cow i will be assigned for her milking period.
Sample Input
5 1 10 2 4 3 6 5 8 4 7
Sample Output
4 1 2 3 2 4
Hint
Explanation of the sample:
Here's a graphical schedule for this output:
Time 1 2 3 4 5 6 7 8 9 10 Stall 1 c1>>>>>>>>>>>>>>>>>>>>>>>>>>> Stall 2 .. c2>>>>>> c4>>>>>>>>> .. .. Stall 3 .. .. c3>>>>>>>>> .. .. .. .. Stall 4 .. .. .. c5>>>>>>>>> .. .. ..
Other outputs using the same number of stalls are possible.
AC代码:
#include<cstdio>
#include<stdlib.h>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstring>
#pragma warning(disable:4996)
using namespace std;
#include<string>
#include<vector>
#include<map>
#include<set>
#include<stack>
#include<queue>
#include<unordered_map>
#include<unordered_set>
const int maxn = 100 + 10;
const int INF = 0x7fffffff;
const double eps = 1e-6;
struct cow_info {//牛的编号,开始结束时间,所在畜栏编号
int num;
int st, ed;
int stall_id;
};
bool cmp1(cow_info &x, cow_info &y) {
return x.st < y.st;
}
bool cmp2(cow_info &x, cow_info &y) {
return x.num < y.num;
}
struct stall_info {//畜栏编号,结束时间
int num;
int ed;
bool operator < (const stall_info & x) const {
return ed > x.ed;
}
stall_info(int _num, int _ed) :num(_num), ed(_ed) {};
};
int n;
int main() {
scanf("%d", &n);
vector<cow_info> cow(n);
for (int i = 0; i < n; i++) {
scanf("%d %d", &cow[i].st, &cow[i].ed);
cow[i].num = i;
}
sort(cow.begin(), cow.end(), cmp1);//按照开始时间从小到大排序
priority_queue<stall_info> stall;
int index = 0, total = 0;//当前牛编号,畜栏总数
while (index < n) {
if (stall.empty()) {//开始时没有畜栏
stall.push(stall_info(++total, cow[index].ed));
cow[index].stall_id = total;
}
else {
stall_info temp = stall.top();
//最早空出畜栏的结束时间等于或晚于当前牛的开始时间,就新增一个畜栏
if (temp.ed >= cow[index].st) {
stall.push(stall_info(++total, cow[index].ed));
cow[index].stall_id = total;
}
//否则把当前牛放到最早结束的畜栏里,并更新畜栏信息
else {
stall.pop();
cow[index].stall_id = temp.num;
temp.ed = cow[index].ed;
stall.push(temp);
}
}
index++;
}
sort(cow.begin(), cow.end(), cmp2);//按照序号从小到达排序,以满足输出要求
printf("%d\n", total);
for (int i = 0; i < n; i++)
printf("%d\n", cow[i].stall_id);
return 0;
}