分数的四则运算和化简---1088 Rational Arithmetic (20 分)

1088 Rational Arithmetic (20 分)

For two rational numbers, your task is to implement the basic arithmetics, that is, to calculate their sum, difference, product and quotient.

Input Specification:

Each input file contains one test case, which gives in one line the two rational numbers in the format a1/b1 a2/b2. The numerators and the denominators are all in the range of long int. If there is a negative sign, it must appear only in front of the numerator. The denominators are guaranteed to be non-zero numbers.

Output Specification:

For each test case, print in 4 lines the sum, difference, product and quotient of the two rational numbers, respectively. The format of each line is number1 operator number2 = result. Notice that all the rational numbers must be in their simplest form k a/b, where k is the integer part, and a/b is the simplest fraction part. If the number is negative, it must be included in a pair of parentheses. If the denominator in the division is zero, output Inf as the result. It is guaranteed that all the output integers are in the range of long int.

Sample Input 1:

2/3 -4/2

Sample Output 1:

2/3 + (-2) = (-1 1/3)
2/3 - (-2) = 2 2/3
2/3 * (-2) = (-1 1/3)
2/3 / (-2) = (-1/3)

Sample Input 2:

5/3 0/6

Sample Output 2:

1 2/3 + 0 = 1 2/3
1 2/3 - 0 = 1 2/3
1 2/3 * 0 = 0
1 2/3 / 0 = Inf

AC代码:

#include<cstdio>
#include<stdlib.h>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstring>
#pragma warning(disable:4996)
using namespace std;
#include<string>
#include<vector>
#include<map>
#include<set>
#include<stack>
#include<queue>
#include<list>
#include<unordered_map>
#include<unordered_set>
const int maxn = 10000 + 10;
const int INF = 0x3f3f3f3f;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int sqrtn = 316;
typedef long long int ll;
struct info {
	ll fzi, fmu;
};
int gcd(ll a, ll b) {
	if (b == 0)return a;
	return gcd(b, a%b);
}
info huajian(info x) {
	if (x.fzi > 0 && x.fmu < 0 || x.fzi < 0 && x.fmu < 0) {//调整符号
		x.fzi = -x.fzi;
		x.fmu = -x.fmu;
	}
	int yue = gcd(abs(x.fzi), abs(x.fmu));
	x.fzi /= yue;
	x.fmu /= yue;
	return x;
}
void print(info x) {
	if (x.fmu == 1) {
		if (x.fzi < 0)printf("(%lld)", x.fzi);
		else printf("%lld", x.fzi);
		return;
	}
	int flag = 0;
	if (x.fzi < 0) {
		printf("(-");
		flag = 1;
		x.fzi = -x.fzi;
	}
	if (x.fzi > x.fmu) {
		printf("%lld ", x.fzi / x.fmu);
		x.fzi = x.fzi%x.fmu;

	}
	printf("%lld/%lld", x.fzi, x.fmu);
	if (flag == 1)printf(")");
}
info Add(info x, info y) {
	info ans;
	ans.fzi = x.fzi*y.fmu + x.fmu*y.fzi;
	ans.fmu = x.fmu*y.fmu;
	return huajian(ans);
}
info Sub(info x, info y) {
	y.fzi = -y.fzi;
	return Add(x, y);
}
info Multi(info x, info y) {
	info ans;
	ans.fzi = x.fzi*y.fzi;
	ans.fmu = x.fmu*y.fmu;
	return huajian(ans);
}
info Divide(info x, info y) {
	info ans;
	ans.fzi = x.fzi*y.fmu;
	ans.fmu = x.fmu*y.fzi;
	return huajian(ans);
}
void print_first(char c, info x, info y) {
	print(huajian(x));
	printf(" %c ", c);
	print(huajian(y));
	printf(" = ");
}
int main() {
	info x, y;
	scanf("%lld/%lld %lld/%lld", &x.fzi, &x.fmu, &y.fzi, &y.fmu);
	print_first('+', x, y);
	print(Add(x, y));
	printf("\n");
	print_first('-', x, y);
	print(Sub(x, y));
	printf("\n");
	print_first('*', x, y);
	print(Multi(x, y));
	printf("\n");
	print_first('/', x, y);
	if (y.fzi == 0)printf("Inf");
	else print(Divide(x, y));
	return 0;
}
/*
2/3 -4/2
2/3 6/-3
2/3 7/-4
*/

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值