AP-Week1 Bridge

题目链接:ZOJ

Bridge

Time Limit: 2000 msMemory Limit: 65536 KB

n people wish to cross a bridge at night. A group of at most two people may cross at any time, and each group must have a flashlight. Only one flashlight is available among the n people, so some sort of shuttle arrangement must be arranged in order to return the flashlight so that more people may cross.

Each person has a different crossing speed; the speed of a group is determined by the speed of the slower member. Your job is to determine a strategy that gets all n people across the bridge in the minimum time.


Input

The first line of input contains n, followed by n lines giving the crossing times for each of the people. There are not more than 1000 people and nobody takes more than 100 seconds to cross the bridge.

Input contains multiple test cases. Process to the end of file.


Output

The first line of output must contain the total number of seconds required for all n people to cross the bridge. The following lines give a strategy for achieving this time. Each line contains either one or two integers, indicating which person or people form the next group to cross. (Each person is indicated by the crossing time specified in the input. Although many people may have the same crossing time the ambiguity is of no consequence.) Note that the crossings alternate directions, as it is necessary to return the flashlight so that more may cross. If more than one strategy yields the minimal time, any one will do.


Sample Input

4
1
2
5
10


Sample Output

17
1 2
1
5 10
2
1 2

//Algorithm Practice Week1
//https://zoj.pintia.cn/problem-sets/91827364500/problems/91827365376
//2021-10-3 17:13-17:27, 18:27-19:27
#include <cstdio>
#include <algorithm>
#include <vector>
using namespace std;
#define maxn 1005
int n, a[maxn];
int main(){
    while(scanf("%d", &n)!=EOF){
            for(int i=1; i<=n; i++)
        scanf("%d", &a[i]);
    sort(a+1, a+n+1);
    if(n==1){
        printf("%d\n%d\n", a[1], a[1]);
        continue;
    }
    int N=n, ans=0;
    while(n>3){
        if(a[1] + a[n-1] < 2*a[2])
            ans += a[n] + a[n-1] + 2*a[1];
        else
            ans += a[n] + a[1] + 2*a[2];
        n -= 2;
    }
    if(n==2)
        ans += a[2];
    else
        ans += a[1] + a[2] + a[3];
    printf("%d\n", ans);

    n=N;
    while(n>3){
        if(a[1] + a[n-1] < 2*a[2])//最快的护送两个慢的
            printf("%d %d\n%d\n%d %d\n%d\n", a[1], a[n], a[1], a[1], a[n-1], a[1]);

        else
            printf("%d %d\n%d\n%d %d\n%d\n", a[1], a[2], a[1], a[n-1], a[n], a[2]);
        n -= 2;
    }
    if(n==2)
        printf("%d %d\n", a[1], a[2]);
    else
        printf("%d %d\n%d\n%d %d\n", a[1], a[3], a[1], a[1], a[2]);
    }
    return 0;
}

考虑最慢的两个人怎么过,是要第一个人来回跑,还是让第二快的人也来帮忙。注意,答案错误先看一下是单组输入还是多组。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值