AP-Week1 Ants

本文介绍了ZOJ算法竞赛中的一道题目,涉及到蚂蚁在杆上行走并相遇的情况。题目要求计算所有蚂蚁最早和最晚可能全部掉落杆的时间。算法核心在于理解蚂蚁相遇后的方向改变,并据此计算最早和最晚掉落时间。程序实现使用了动态规划的思想,通过不断更新最早和最晚时间来求解。
摘要由CSDN通过智能技术生成

题目链接:ZOJ

Ants

Time Limit: 2000 msMemory Limit: 65536 KB

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time.

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

4 8
38 207

//Algorithm Practice Week1
//https://zoj.pintia.cn/problem-sets/91827364500/problems/91827365851
//2021-10-6 9:01-9:23
#include <cstdio>
#include <algorithm>
#include <vector>
using namespace std;
#define maxn 1005
int main(){
    int t, l, n, ealiest = 0, latest = 0, temp;
    scanf("%d", &t);
    while(t--){
        scanf("%d%d%d", &l, &n, &temp);
        ealiest = min(temp, l-temp);
        latest = max(temp, l-temp);
//        printf("n:%d, ealiest:%d, latest:%d\n", n, ealiest, latest);
        n--;
        while(n--){
            scanf("%d", &temp);
            ealiest = max(min(temp, l-temp), ealiest);
            latest = max(max(temp, l-temp), latest);
//            printf("n:%d, ealiest:%d, latest:%d\n", n, ealiest, latest);
        }

        printf("%d %d\n", ealiest, latest);
    }
    return 0;
}

把蚂蚁的相遇看成即使相遇也不理睬对方而继续走自己的路,这样每只蚂蚁掉落的时间要么是从开始位置向左走的时间,要么是向右走的时间。全部掉落的最早时间就是所有蚂蚁尽快掉落时间的最大值,注意是最大值!全部掉落的最晚时间就是所有蚂蚁尽慢掉落时间的最大值。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值