给出4个小于10的正整数,你可以使用加减乘除4种运算以及括号把这4个数连接起来得到一个表达式。现在的问题是,是否存在一种方式使得得到的表达式的结果等于24。比如对于5,5,5,1,我们知道5*(5-1-1/5)=24可以得到24。
输入包括多行,每行给出一组测试数据,包括4个小于10的正整数,最后一组测试数据中包括4个0,表示输入的结束,这组数据不用处理。
对于每一组测试数据,输出一行,如果可以得到24,输出“YES”,否则,输出“NO”。
样例输入:
5 5 5 1
11 4 2
0 0 0 0
样例输出:
YES
NO
#include <iostream>
#include <cstdio>
#include <cmath>
#define eps 1e-6
using namespace std;
//第一步,拿两个数先算一下
//注意!!!浮点数比较是否相等,不能用==。应该看它们的差是否小于某个很小的值
double a[5];
bool iszero(double x){
return fabs(x)<=eps;
}
bool count24(double a[],int n){
if(n==1){
if(iszero(a[0]-24))
return true;
else
return false;
}
double b[5];
for(int i=0;i<n-1;++i){
for(int j=i+1;j<n;++j){
int m=0;
for(int k=0;k<n;++k)
if(k!=i&&k!=j)
b[m++]=a[k];
b[m]=a[i]+a[j];
if(count24(b,m+1))
return true;
b[m]=a[i]-a[j];//注意减法有两种
if(count24(b,m+1))
return true;
b[m]=a[j]-a[i];
if(count24(b,m+1))
return true;
b[m]=a[i]*a[j];
if(count24(b,m+1))
return true;
if(!iszero(a[j])){
b[m]=a[i]/a[j];
if(count24(b,m+1))
return true;
}
if(!iszero(a[i])){
b[m]=a[j]/a[i];
if(count24(b,m+1))
return true;
}
}
}
return false;
}
int main(){
while(true){
for(int i=0;i<4;++i)
cin>>a[i];
if(iszero(a[0]))
break;
if(count24(a,4))
cout<<"YES"<<endl;
else cout<<"NO"<<endl;
}
return 0;
}