模板:母函数

hdu 1398

```

People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland. 
There are four combinations of coins to pay ten credits: 

ten 1-credit coins, 
one 4-credit coin and six 1-credit coins, 
two 4-credit coins and two 1-credit coins, and 
one 9-credit coin and one 1-credit coin. 

Your mission is to count the number of ways to pay a given amount using coins of Silverland. 
Input
The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300. 
Output
For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output. 
Sample Input
2
10
30
0
Sample Output
1
4
27
```

#include<stdio.h>
#include<string.h>
int from[301],to[301],n;
int main() {
	while(scanf("%d",&n)&&n) {
		memset(from,0,sizeof(from));
		memset(to,0,sizeof(to));
		from[0]=1;
		for(int i=1;i*i<=n;i++) {
			for(int j=0;j<=n;j+=i*i) {
				for(int k=0;j+k<=n;k++) {
					to[j+k]+=from[k];
				}
			}
			memcpy(from,to,sizeof(to));
			memset(to,0,sizeof(to));
		}
		printf("%d\n",from[n]);
	}
}


hdu 1028

```

"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says. 

"The second problem is, given an positive integer N, we define an equation like this: 
  N=a[1]+a[2]+a[3]+...+a[m]; 
  a[i]>0,1<=m<=N; 
My question is how many different equations you can find for a given N. 
For example, assume N is 4, we can find: 
  4 = 4; 
  4 = 3 + 1; 
  4 = 2 + 2; 
  4 = 2 + 1 + 1; 
  4 = 1 + 1 + 1 + 1; 
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!" 
Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file. 
Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found. 
Sample Input
4
10
20
Sample Output
5
42
627
```


#include<stdio.h>
#include<string.h>
#include<algorithm>
int from[121],to[121],n;
int main() {
	while(scanf("%d",&n)!=EOF) {
		memset(from,0,sizeof(from));
		memset(to,0,sizeof(to));
		from[0]=1;
		for(int i=1;i<=n;i++) {
			for(int j=0;j<=n;j+=i) {
				for(int k=0;j+k<=n;k++) {
					to[j+k]+=from[k];
				}
			}
			memcpy(from,to,sizeof(to));
			memset(to,0,sizeof(to));
		}
		printf("%d\n",from[n]);
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值