POJ 2488 A Knight's Journey

18 篇文章 0 订阅
11 篇文章 0 订阅

A Knight's Journey
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 44642 Accepted: 15167

Description

Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

题意:n行m列的棋盘,马以 L 型走,问马可以全部的棋盘格都走过一遍吗?

//dfs代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>

using namespace std;
int p,q,step;
bool f;
const int maxn = 30;
int vst[maxn][maxn];
int dir[8][2] = {{-2,-1},{-2,1},{-1,-2},{-1,2},{1,-2},{1,2},{2,-1},{2,1}};
struct node
{
    int x;
    int y;
}res[maxn];

void dfs(int x,int y)
{
    if(f)
        return ;
    ++step;
    vst[x][y] = 1;// 标记该节点被访问过  
    res[step].x = x;//每一步的坐标
    res[step].y = y;
    if(step == p*q&&f == false)//
    {
        f = true;
        for(int i=1;i<=step;i++)
        {
            char c = res[i].x - 1+'A';
            cout<<c<<res[i].y;
        }
        cout<<endl;
        cout<<endl;
        return;
    }
    for(int i=0;i<8;i++)//遍历
    {
        int ex = x + dir[i][0];
        int ey = y + dir[i][1];
        if(ex >= 1&&ex<=q&&ey>=1&&ey<=p&&!vst[ex][ey])
            {
                dfs(ex,ey);
                step++;
            }
    }
}

int main()
{
    //ios::sync_with_stdio(false);
    int n;
    cin>>n;
    for(int i=1;i<=n;i++)
    {
        step = 0;
        memset(vst,0,sizeof(vst));
        cout<<"Scenario #"<<i<<":"<<endl;
        cin>>p>>q;
        f = false;
        dfs(1,1);
        if(!f)
        {
            cout<<"impossible"<<endl<<endl;
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Usher_Ou

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值