HDU 1394

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7907    Accepted Submission(s): 4851


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
  
  
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
  
  
16
 

Author
CHEN, Gaoli
 

Source
 

Recommend
Ignatius.L
 

Statistic |  Submit |  Discuss |  Note

数状数组维护。。。。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>

using namespace std;

#define nMax 5010

int a[nMax],n;
int c[nMax];
int lowbit(int x) {
	return x&(-x);
}
void add(int x,int k) {
	while(x<=n) {
		c[x] += k;
		x += lowbit(x);
	}
}
int sum(int x) {
	int ret=0;
	while(x>0) {
		ret += c[x];
		x -= lowbit(x);
	}
	return ret;
}

int main() {
//	freopen("input.txt","r",stdin);
	while(~scanf("%d",&n)) {
		int ret=0;memset(c,0,sizeof(c));
		for(int i=0;i<n;i++) {
			scanf("%d",&a[i]);
			ret += sum(n) - sum(a[i]);
			add(a[i]+1,1);
		}
		int ans = ret;
		for(int i=0;i<n;i++) {
			int res = ret - a[i];
			res += n-a[i]-1;
			if(res < ans) ans=res;
			ret = res;
		}
		printf("%d\n",ans);
	}
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值