sgu 160 Magic Multiplying Machine

18 篇文章 0 订阅
160. Magic Multiplying Machine
time limit per test: 1 sec.
memory limit per test: 65536 KB
input: standard input
output: standard output



Well known Las-Vegas casino "Big Jo" has recently introduced the new playing machine, called Magic Multiplying Machine (MMM). MMM has N levers and one big red button. Each lever is marked with some integer number ranging from 1 to M, thus i-th lever is marked with number ai.
A player who wishes to play on MMM inserts a coin into a special slot. After that she chooses some levers and pulls them. After she has made her choice, she presses the big red button. MMM blinks all its lights, rings its bells, plays diRerent tunes and after that declares whether the player has won the game.
The algorithm for determining whether the player has won is the following. If the player has pulled some subset S in {1, 2, ... ,N} of levers, her score is the product of numbers that these levers are marked with, taken modulo M (if the player has pulled no levers, her score is 1):

The player has won the game if her score is maximal possible for the given machine.
Given the description of some MMM determine which levers should be pulled to win the game.

Input
The first line of the input file contains two integer numbers 1 <= N <= 10000 and 2 <= M <= 1 000. The second line contains N integer numbers a1, a2, ..., aN ranging from 1 to M.

Output
In the first line of the output file print one integer number - the score that should be obtained to win the game. In the second line print in ascending order the numbers of levers that should be pulled to obtain this score (levers are numbered starting from one). If there are several solutions, output any one.

Sample test(s)

Input
Sample input #1
4 6
1 2 3 4

Sample input #2
4 4
4 4 4 4

Output
Sample output #1
4
1 4

Sample output #2
1

Note

You can download pdf version of this task here

Author:Andrew Lopatin, Nikolay Durov
Resource:ACM ICPC 2002-2003 NEERC, Northern Subregion
Date:November, 2002







#include<iostream>
#include<cstring>
#include<cstdio>
#include<set>
#include<algorithm>
#include<vector>
#include<cstdlib>

#define inf 0xfffffff
#define CLR(a,b) memset((a),(b),sizeof((a)))
#define FOR(a,b) for(int a=1;a<=(b);(a)++)

using namespace std;
int const nMax = 1010;
int const base = 10;
typedef int LL;
typedef pair<LL,LL> pij;

//    std::ios::sync_with_stdio(false);

set<int> Q;
set<int> :: iterator it,be,ed;
pij s[nMax];
int n,m;
int a,b;
bool vis[nMax];
vector<int> add;

void output(int a){
    if(a==-1) return ;
    Q.insert(s[a].second);
    output(s[a].first);
    return ;
}

int main(){
    scanf("%d%d",&n,&m);
    CLR(vis,0);
    Q.clear();
    FOR(i,n)  {
        scanf("%d",&a);
        a%=m;
        add.clear();
        if(!vis[a]){
            vis[a]=true;
            s[a]=make_pair(-1,i);
            add.push_back(a);
        }
        for(it=Q.begin();it!=Q.end();it++) {
            b=(*it)*a%m;
            if(!vis[b]) {
                vis[b]=true;
                s[b]=make_pair(*it,i);
                add.push_back(b);
            }
        }
        for(int j=0;j<add.size();j++) Q.insert(add[j]);
    }
    for(int i=m-1;i>=0;i--)if(vis[i]){
        if(i==0){
            return printf("1\n"),0;
        }
        printf("%d\n",i);
        Q.clear();
        output(i);
        break;
    }
    for(it=Q.begin();it!=Q.end();it++){
        printf("%d ",*it);
    }
    printf("\n");
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值