CodeForces 731 A.Night at the Museum(水~)

Description
一个键盘如下:
这里写图片描述
问至少转多少格可以打出串s
Input
一个字符串s,串长不超过100
Output
输出打出s最少需要转多少格
Sample Input
zeus
Sample Output
18
Solution
简单题,每次顺时针转和逆时针转取个较小值
Code

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
#define INF 0x3f3f3f3f
#define maxn 111
char s[maxn]; 
int main()
{
    while(~scanf("%s",s))
    {
        int n=strlen(s),ans=0,pre=0;
        for(int i=0;i<n;i++)
        {
            int t=s[i]-'a';
            ans+=min(abs(t-pre),26-abs(t-pre));
            pre=t;
        }
        printf("%d\n",ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值