PAT-甲级-1013 Battle Over Cities (25 分)

60 篇文章 0 订阅
20 篇文章 0 订阅

1013 Battle Over Cities (25 分)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city​1​​-city​2​​ and city​1​​-city​3​​. Then if city​1​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city​2​​-city​3​​.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then Mlines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

题目大意:给出关于n个城市的高速连通关系,查询k个城市,当该城市被攻占时,应该修复几条高速才能让其他n-1个城市连通;即计算图的连通分量数,当从查询结点可以遍历整张图时,连通分量为1,需要修复的高速数为0。

解题思路:

  • 用二维vector保存图的关系;
  •  k次查询中,先将查询结点置为true,表示将该节点分割。
  • for循环判断n个结点是否被访问,未被访问的dfs递归访问。
#include <vector>
#include <iostream>
#include <algorithm>
using namespace std;
#define rep(i,j,k)    for(int i=j;i<k;i++)
const int maxn=1010;

vector<int> v[maxn];
bool vis[maxn];
void dfs(int u){
    vis[u] = true;
    rep(i,0,v[u].size())
        if(vis[v[u][i]]==false)
            dfs(v[u][i]);
}
int main(){
    int n,m,k,a,b;
    scanf("%d %d %d",&n,&m,&k);
    rep(i,0,m){
        scanf("%d %d",&a,&b);
        v[a].push_back(b);
        v[b].push_back(a);
    }
    rep(i,0,k){
        int cnt = 0;
        fill(vis,vis+maxn,false);
        scanf("%d",&a);
        vis[a] = true;
        rep(j,1,n+1){
            if(vis[j]==false){
                dfs(j);
                cnt++;
            }
        }
        printf("%d\n",cnt-1);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值