PAT-甲级-1130 Infix Expression(25分)

60 篇文章 0 订阅

1130 Infix Expression (25 分)

Given a syntax tree (binary), you are supposed to output the corresponding infix expression, with parentheses reflecting the precedences of the operators.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20) which is the total number of nodes in the syntax tree. Then N lines follow, each gives the information of a node (the i-th line corresponds to the i-th node) in the format:

data left_child right_child

where data is a string of no more than 10 characters, left_child and right_child are the indices of this node's left and right children, respectively. The nodes are indexed from 1 to N. The NULL link is represented by −1. The figures 1 and 2 correspond to the samples 1 and 2, respectively.

infix1.JPGinfix2.JPG
Figure 1Figure 2

Output Specification:

For each case, print in a line the infix expression, with parentheses reflecting the precedences of the operators. Note that there must be no extra parentheses for the final expression, as is shown by the samples. There must be no space between any symbols.

Sample Input 1:

8
* 8 7
a -1 -1
* 4 1
+ 2 5
b -1 -1
d -1 -1
- -1 6
c -1 -1

Sample Output 1:

(a+b)*(c*(-d))

Sample Input 2:

8
2.35 -1 -1
* 6 1
- -1 4
% 7 8
+ 2 3
a -1 -1
str -1 -1
871 -1 -1

Sample Output 2:

(a*2.35)+(-(str%871))

题目大意:给定一棵表达式树,输出带括号的算术表达式;

解题思路:

  • 记录出现过的孩子结点,未出现的即为根结点;
  • dfs访问,返回string:
    • 访问为叶子节点时,返回“”;
    • 访问右子树不为空时,返回“左子树+“该节点”+“右子树”;
    • 当不是根结点时,给当前表达式加括号。 
#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
using namespace std;
#define rep(i,j,k)    for(int i=j;i<k;i++)
struct node{
    string d;
    int l,r;
};
vector<node> v;
string ans;
int root = 1;
string dfs(int u){
    if(u==-1)
        return "";
    if(v[u].r != -1){
        v[u].d = dfs(v[u].l) + v[u].d + dfs(v[u].r);
        if(u!=root)v[u].d = '(' + v[u].d + ')';
    }
    return v[u].d;
}
int main(){
    std::ios::sync_with_stdio(false);
    int n,a,b;
    string d;
    cin>>n;
    v.resize(n+1);
    vector<int> cnt(n+1,0);
    rep(i,1,n+1){
        cin>>d>>a>>b;
        node no={d,a,b};
        v[i] = no;
        if(a != -1)
            cnt[a] = 1;
        if(b != -1)
            cnt[b] = 1;
    }
    while(cnt[root]!=0)    root++;
    cout<<dfs(root);
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值