PAT-甲级-1100 Mars Numbers (20 分)

60 篇文章 0 订阅

People on Mars count their numbers with base 13:

  • Zero on Earth is called "tret" on Mars.
  • The numbers 1 to 12 on Earth is called "jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec" on Mars, respectively.
  • For the next higher digit, Mars people name the 12 numbers as "tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou", respectively.

For examples, the number 29 on Earth is called "hel mar" on Mars; and "elo nov" on Mars corresponds to 115 on Earth. In order to help communication between people from these two planets, you are supposed to write a program for mutual translation between Earth and Mars number systems.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<100). Then N lines follow, each contains a number in [0, 169), given either in the form of an Earth number, or that of Mars.

Output Specification:

For each number, print in a line the corresponding number in the other language.

Sample Input:

4
29
5
elo nov
tam

Sample Output:

hel mar
may
115
13

题目大意:火星与地球的数字系统存在差异,火星上采用13进制数字系统,请将火星和地球数字互相翻译;

解题思路:

  • 关于带空格的输入字符串处理:
#include <string>
#include <sstream>
#include <iostream>
using namespace std;

int main(){
    ​​​​​​​stringstream ss;
    string s = "i am is a studnet";
    ss << s;
    while(ss >> s){
        cout<< s<<endl;
    }
    return 0;
}
#include <iostream>
#include <vector>
#include <sstream>
#include <string>
using namespace std;
#define rep(i,j,k) for(int i=j;i<k;i++)

int main(){
    int n,c;
    string a[13]={"tret","jan", "feb", "mar", "apr","may","jun", "jly", "aug", "sep", "oct",
        "nov","dec"};
    string b[13]={ "0","tam", "hel", "maa", "huh", "tou", "kes",
        "hei", "elo", "syy", "lok", "mer", "jou"};
    string num;
    cin>>n;getchar();
    rep(i,0,n){
        getline(cin,num);
        if(isdigit(num[0])){
            c=stoi(num);
            if(c>=13){
                cout<<b[c/13];
                if(c%13!=0)
                    cout<<" "<<a[c%13];
            }else cout<<a[c%13];
            cout<<"\n";
        }else{
            stringstream ss;
            int ans=0;
            ss<<num;
            while(ss>>num){
                rep(j,0,13){
                    if(num==a[j])
                        ans+=j;
                    if(num==b[j])
                        ans+=(j*13);
                }
            }
            cout<<ans<<"\n";
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值